summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Dewender <github@JonnyJD.net>2013-10-25 16:44:41 +0200
committerJohannes Dewender <github@JonnyJD.net>2013-10-25 17:01:12 +0200
commit8302169b5a06d43cc2f61a1648490a3e18f5f45b (patch)
tree5ea28c5a98c74a2b83e14ff39306664df7d21f6f
parent3ee17b0f78972dc4951ebcffcdd000631e5cebae (diff)
downloadtargetcli-8302169b5a06d43cc2f61a1648490a3e18f5f45b.tar.gz
rename debian package to targetcli-fb
The name "targetcli" is already used for the original package on Debian. Signed-off-by: Johannes Dewender <github@JonnyJD.net>
-rw-r--r--Makefile37
-rw-r--r--debian/control12
-rw-r--r--debian/copyright4
-rw-r--r--debian/targetcli-fb-doc.docs (renamed from debian/targetcli-doc.docs)0
-rw-r--r--debian/targetcli-fb.dirs (renamed from debian/targetcli.dirs)0
-rw-r--r--debian/targetcli-fb.docs (renamed from debian/targetcli.docs)0
-rw-r--r--debian/targetcli-fb.install (renamed from debian/targetcli.install)0
-rwxr-xr-xdebian/targetcli-fb.postinst (renamed from debian/targetcli.postinst)0
-rwxr-xr-xdebian/targetcli-fb.preinst (renamed from debian/targetcli.preinst)0
-rwxr-xr-xdebian/targetcli-fb.prerm (renamed from debian/targetcli.prerm)0
10 files changed, 27 insertions, 26 deletions
diff --git a/Makefile b/Makefile
index fe188e2..e12f279 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,4 @@
+PKGNAME = targetcli-fb
NAME = targetcli
GIT_BRANCH = $$(git branch | grep \* | tr -d \*)
VERSION = $$(basename $$(git describe --tags | tr - . | sed 's/^v//'))
@@ -21,8 +22,8 @@ clean:
@rm -fv dpkg-buildpackage.log dpkg-buildpackage.version
@rm -frv *.rpm
@rm -fv debian/files debian/*.log debian/*.substvars
- @rm -frv debian/${NAME}-doc/ debian/python2.5-${NAME}/
- @rm -frv debian/python2.6-${NAME}/ debian/python-${NAME}/
+ @rm -frv debian/${PKGNAME}-doc/ debian/python2.5-${PKGNAME}/
+ @rm -frv debian/python2.6-${PKGNAME}/ debian/python-${PKGNAME}/
@rm -frv results
@rm -fv rpm/*.spec *.spec rpm/sed* sed*
@rm -frv ${NAME}-*
@@ -40,17 +41,17 @@ release: build/release-stamp
build/release-stamp:
@mkdir -p build
@echo "Exporting the repository files..."
- @git archive ${GIT_BRANCH} --prefix ${NAME}-${VERSION}/ \
+ @git archive ${GIT_BRANCH} --prefix ${PKGNAME}-${VERSION}/ \
| (cd build; tar xfp -)
@echo "Cleaning up the target tree..."
- @rm -f build/${NAME}-${VERSION}/Makefile
- @rm -f build/${NAME}-${VERSION}/.gitignore
- @rm -rf build/${NAME}-${VERSION}/bin
+ @rm -f build/${PKGNAME}-${VERSION}/Makefile
+ @rm -f build/${PKGNAME}-${VERSION}/.gitignore
+ @rm -rf build/${PKGNAME}-${VERSION}/bin
@echo "Fixing version string..."
@sed -i "s/__version__ = .*/__version__ = '${VERSION}'/g" \
- build/${NAME}-${VERSION}/${NAME}/__init__.py
+ build/${PKGNAME}-${VERSION}/${NAME}/__init__.py
@echo "Generating rpm specfile from template..."
- @cd build/${NAME}-${VERSION}; \
+ @cd build/${PKGNAME}-${VERSION}; \
for spectmpl in rpm/*.spec.tmpl; do \
sed -i "s/Version:\( *\).*/Version:\1${VERSION}/g" $${spectmpl}; \
mv $${spectmpl} $$(basename $${spectmpl} .tmpl); \
@@ -65,7 +66,7 @@ build/release-stamp:
hash=$$(git show HEAD --format="format:%H" -s); \
echo '* '"$${date} $${author} $${version}-1"; \
echo " - Generated from git commit $${hash}."; \
- ) >> $$(ls build/${NAME}-${VERSION}/*.spec)
+ ) >> $$(ls build/${PKGNAME}-${VERSION}/*.spec)
@echo "Generating debian changelog..."
@( \
version=${VERSION}; \
@@ -77,30 +78,30 @@ build/release-stamp:
date=$$(echo $${date} \
| awk '{print $$1, "'"$${day}"'", $$3, $$4, $$5, $$6}'); \
hash=$$(git show HEAD --format="format:%H" -s); \
- echo "${NAME} ($${version}) unstable; urgency=low"; \
+ echo "${PKGNAME} ($${version}) unstable; urgency=low"; \
echo; \
echo " * Generated from git commit $${hash}."; \
echo; \
echo " -- $${author} $${date}"; \
echo; \
- ) > build/${NAME}-${VERSION}/debian/changelog
- @find build/${NAME}-${VERSION}/ -exec \
+ ) > build/${PKGNAME}-${VERSION}/debian/changelog
+ @find build/${PKGNAME}-${VERSION}/ -exec \
touch -t $$(date -d @$$(git show -s --format="format:%at") \
+"%Y%m%d%H%M.%S") {} \;
@mkdir -p dist
@cd build; tar -c --owner=0 --group=0 --numeric-owner \
--format=gnu -b20 --quoting-style=escape \
- -f ../dist/${NAME}-${VERSION}.tar \
- $$(find ${NAME}-${VERSION} -type f | sort)
- @gzip -6 -n dist/${NAME}-${VERSION}.tar
+ -f ../dist/${PKGNAME}-${VERSION}.tar \
+ $$(find ${PKGNAME}-${VERSION} -type f | sort)
+ @gzip -6 -n dist/${PKGNAME}-${VERSION}.tar
@echo "Generated release tarball:"
- @echo " $$(ls dist/${NAME}-${VERSION}.tar.gz)"
+ @echo " $$(ls dist/${PKGNAME}-${VERSION}.tar.gz)"
@touch build/release-stamp
deb: release build/deb-stamp
build/deb-stamp:
@echo "Building debian packages..."
- @cd build/${NAME}-${VERSION}; \
+ @cd build/${PKGNAME}-${VERSION}; \
dpkg-buildpackage -rfakeroot -us -uc
@mv build/*_${VERSION}_*.deb dist/
@echo "Generated debian packages:"
@@ -114,7 +115,7 @@ build/rpm-stamp:
@build=$$(pwd)/build/rpm; dist=$$(pwd)/dist/; rpmbuild \
--define "_topdir $${build}" --define "_sourcedir $${dist}" \
--define "_rpmdir $${build}" --define "_buildir $${build}" \
- --define "_srcrpmdir $${build}" -ba build/${NAME}-${VERSION}/*.spec
+ --define "_srcrpmdir $${build}" -ba build/${PKGNAME}-${VERSION}/*.spec
@mv build/rpm/*-${VERSION}*.src.rpm dist/
@mv build/rpm/*/*-${VERSION}*.rpm dist/
@echo "Generated rpm packages:"
diff --git a/debian/control b/debian/control
index af078bc..f851573 100644
--- a/debian/control
+++ b/debian/control
@@ -1,15 +1,15 @@
-Source: targetcli
+Source: targetcli-fb
Section: python
Priority: optional
-Maintainer: Jerome Martin <jxm@risingtidesystems.com>
+Maintainer: Andy Grover <andy@groveronline.com>
Build-Depends: debhelper(>= 5.0.1), python2.6, build-essential, python-dev, python2.6-dev, python-epydoc, zlib1g-dev, python-configshell, python-rtslib
Standards-Version: 3.8.1
-Package: targetcli
+Package: targetcli-fb
Architecture: all
Depends: python (>= 2.6)|python2.6, python-configshell, python-rtslib, lio-utils
-Suggests: targetcli-doc
-Conflicts: targetcli-frozen
-Description: CLI shell for the RisingTide Systems target.
+Suggests: targetcli-fb-doc
+Conflicts: targetcli, targetcli-frozen
+Description: CLI shell for the RisingTide Systems target (free branch).
.
This package contains the targetcli CLI.
diff --git a/debian/copyright b/debian/copyright
index 253cf82..7b0b96c 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,6 +1,6 @@
This package was originally debianized by Jerome Martin <jxm@risingtidesystems.com>
-on Thu Nov 19 12:00:01 UTC 2009. It is currently maintained by Jerome Martin
-<jxm@risingtidesystems.com>.
+on Thu Nov 19 12:00:01 UTC 2009. It is currently maintained by Andy Grover
+<andy@groveronline.com>.
Upstream Author: Jerome Martin <jxm@risingtidesystems.com>
diff --git a/debian/targetcli-doc.docs b/debian/targetcli-fb-doc.docs
index 7363993..7363993 100644
--- a/debian/targetcli-doc.docs
+++ b/debian/targetcli-fb-doc.docs
diff --git a/debian/targetcli.dirs b/debian/targetcli-fb.dirs
index f430183..f430183 100644
--- a/debian/targetcli.dirs
+++ b/debian/targetcli-fb.dirs
diff --git a/debian/targetcli.docs b/debian/targetcli-fb.docs
index 7758d58..7758d58 100644
--- a/debian/targetcli.docs
+++ b/debian/targetcli-fb.docs
diff --git a/debian/targetcli.install b/debian/targetcli-fb.install
index 5a1dd4b..5a1dd4b 100644
--- a/debian/targetcli.install
+++ b/debian/targetcli-fb.install
diff --git a/debian/targetcli.postinst b/debian/targetcli-fb.postinst
index 8412fc6..8412fc6 100755
--- a/debian/targetcli.postinst
+++ b/debian/targetcli-fb.postinst
diff --git a/debian/targetcli.preinst b/debian/targetcli-fb.preinst
index 58f5f2a..58f5f2a 100755
--- a/debian/targetcli.preinst
+++ b/debian/targetcli-fb.preinst
diff --git a/debian/targetcli.prerm b/debian/targetcli-fb.prerm
index 7603750..7603750 100755
--- a/debian/targetcli.prerm
+++ b/debian/targetcli-fb.prerm