summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Grover <agrover@redhat.com>2013-09-11 08:41:14 -0700
committerAndy Grover <agrover@redhat.com>2013-09-11 08:41:14 -0700
commita8c1a5c285a439ad8d15bc6a4363fb5246dc93ec (patch)
treeb6b55997ad23d027f7c35e028e612b060f7c9a3c
parentfedfcb6332ecd3b5d37db6212ffbf4d3ae1735b5 (diff)
downloadtargetcli-a8c1a5c285a439ad8d15bc6a4363fb5246dc93ec.tar.gz
Revert "Put version directly in setup.py"
Version is also used in scripts/targetcli. This reverts commit fedfcb6332ecd3b5d37db6212ffbf4d3ae1735b5.
-rwxr-xr-xsetup.py5
-rw-r--r--targetcli/version.py18
2 files changed, 22 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1162546..f49dfcc 100755
--- a/setup.py
+++ b/setup.py
@@ -18,9 +18,12 @@ under the License.
from distutils.core import setup
+__version__ = ''
+execfile('targetcli/version.py')
+
setup(
name = 'targetcli-fb',
- version = '2.1.fb29',
+ version = __version__,
description = 'An administration shell for RTS storage targets.',
license = 'Apache 2.0',
maintainer = 'Andy Grover',
diff --git a/targetcli/version.py b/targetcli/version.py
new file mode 100644
index 0000000..ae4d73a
--- /dev/null
+++ b/targetcli/version.py
@@ -0,0 +1,18 @@
+'''
+This file is part of targetcli.
+Copyright (c) 2011-2013 by Datera, Inc
+
+Licensed under the Apache License, Version 2.0 (the "License"); you may
+not use this file except in compliance with the License. You may obtain
+a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+License for the specific language governing permissions and limitations
+under the License.
+'''
+
+__version__ = '2.1.fb28'