summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-01-02 21:16:15 -0800
committerGitHub <noreply@github.com>2023-01-02 21:16:15 -0800
commitbeb7d66b5575f75d4b660d90ad75c3a56deb8a20 (patch)
tree83298b1c3b93aa75bbbe78a57351b7a69a8f1ce8
parente7fa1c2b4bbbe7495077e5f2146dca9c369b08d7 (diff)
downloadvirtualenv-beb7d66b5575f75d4b660d90ad75c3a56deb8a20.tar.gz
Fix coverage reporting (#2477)
-rw-r--r--pyproject.toml20
1 files changed, 7 insertions, 13 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 053fc2a..f14b417 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -22,7 +22,7 @@ dependencies = [
]
optional-dependencies.test = [
"covdefaults>=2.2.2",
- "coverage>=7.0.1",
+ "coverage>=7.0.2",
"coverage-enable-subprocess>=1",
"flaky>=3.7",
"packaging>=22",
@@ -98,24 +98,18 @@ html.show_contexts = true
html.skip_covered = false
report.omit = [
# site.py is ran before the coverage can be enabled, no way to measure coverage on this
- "src/virtualenv/create/via_global_ref/builtin/python2/site.py",
- "src/virtualenv/create/via_global_ref/_virtualenv.py",
- "src/virtualenv/activation/python/activate_this.py",
- "src/virtualenv/seed/wheels/embed/pip-*.whl/*",
+ "**/src/virtualenv/create/via_global_ref/builtin/python2/site.py",
+ "**/src/virtualenv/create/via_global_ref/_virtualenv.py",
+ "**/src/virtualenv/activation/python/activate_this.py",
+ "**/src/virtualenv/seed/wheels/embed/pip-*.whl/pip/**",
]
-paths.source = [
- "src",
- ".tox/*/lib/*/site-packages", # pypy3.8 + cpython
- ".tox/*/site-packages", # pypy3.7
- ".tox\\*\\Lib\\site-packages", # pypy3.8 + cpython
- ".tox\\*\\site-packages", # pypy3.7
-]
-paths.other = [".", "*/virtualenv", "*\\virtualenv"]
+paths.source = ["src", "**/site-packages"]
report.fail_under = 76
run.source = ["${_COVERAGE_SRC}", "tests"]
run.dynamic_context = "test_function"
run.parallel = true
run.plugins = ["covdefaults"]
+run.relative_files = true
[tool.black]
line-length = 120