summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <xistence@0x58.com>2018-05-20 17:05:21 -0600
committerGitHub <noreply@github.com>2018-05-20 17:05:21 -0600
commit72f9f4383b9484bdb7d3ff44233c3ba234b75426 (patch)
tree5aa4c18bfed6ba85f3d7037b5345b0a66ab254e0
parentb0e6bc0c6d608227fc64ed3048f5d25657d5bf67 (diff)
parent583c347fafafd4653d5b46d88b25b50c0419dfc2 (diff)
downloadwaitress-72f9f4383b9484bdb7d3ff44233c3ba234b75426.tar.gz
Merge pull request #193 from stevepiercy/docs-meta-info
Update meta data
-rw-r--r--RELEASING.txt115
-rw-r--r--docs/conf.py8
2 files changed, 120 insertions, 3 deletions
diff --git a/RELEASING.txt b/RELEASING.txt
new file mode 100644
index 0000000..1306098
--- /dev/null
+++ b/RELEASING.txt
@@ -0,0 +1,115 @@
+Releasing
+=========
+
+- For clarity, we define releases as follows.
+
+ - Alpha, beta, dev and similar statuses do not qualify whether a release is
+ major or minor. The term "pre-release" means alpha, beta, or dev.
+
+ - A release is final when it is no longer pre-release.
+
+ - A *major* release is where the first number either before or after the
+ first dot increases. Examples: 1.0 to 1.1a1, or 0.9 to 1.0.
+
+ - A *minor* or *bug fix* release is where the number after the second dot
+ increases. Example: 1.0 to 1.0.1.
+
+Prepare new release
+-------------------
+
+- Do platform test via tox:
+
+ $ tox -r
+
+ Make sure statement coverage is at 100% (the test run will fail if not).
+
+- Run tests on Windows if feasible.
+
+- Ensure all features of the release are documented (audit CHANGES.txt or
+ communicate with contributors).
+
+- Change CHANGES.txt heading to reflect the new version number.
+
+- Minor releases should include a link under "Bug Fix Releases" to the minor
+ feature changes in CHANGES.txt.
+
+- Change setup.py version to the release version number.
+
+- Make sure PyPI long description renders (requires ``readme_renderer``
+ installed into your Python)::
+
+ $ python setup.py check -r -s -m
+
+- Create a release tag.
+
+- Make sure your Python has ``setuptools-git``, ``twine``, and ``wheel``
+ installed and release to PyPI::
+
+ $ python setup.py sdist bdist_wheel
+ $ twine upload dist/waitress-X.X-*
+
+
+Prepare master for further development (major releases only)
+------------------------------------------------------------
+
+- In CHANGES.txt, preserve headings but clear out content. Add heading
+ "unreleased" for the version number.
+
+- Forward port the changes in CHANGES.txt to HISTORY.txt.
+
+- Change setup.py version to the next version number.
+
+
+Marketing and communications
+----------------------------
+
+- Check `https://wiki.python.org/moin/WebServers
+ <https://wiki.python.org/moin/WebServers>`_.
+
+- Announce to Twitter.
+
+```
+waitress 1.x released.
+
+PyPI
+https://pypi.org/project/waitress/1.x/
+
+=== One time only for new version, first pre-release ===
+What's New
+https://docs.pylonsproject.org/projects/waitress/en/latest/#id2
+=== For all subsequent pre-releases ===
+Changes
+https://docs.pylonsproject.org/projects/waitress/en/latest/#change-history
+
+Documentation:
+https://docs.pylonsproject.org/projects/waitress/en/latest/
+
+Issues
+https://github.com/Pylons/waitress/issues
+```
+
+- Announce to maillist.
+
+```
+waitress 1.X.X has been released.
+
+The full changelog is here:
+https://docs.pylonsproject.org/projects/waitress/en/latest/#change-history
+
+What's New In waitress 1.X:
+https://docs.pylonsproject.org/projects/waitress/en/latest/#id2
+
+Documentation:
+https://docs.pylonsproject.org/projects/waitress/en/latest/
+
+You can install it via PyPI:
+
+ pip install waitress==1.X
+
+Enjoy, and please report any issues you find to the issue tracker at
+https://github.com/Pylons/waitress/issues
+
+Thanks!
+
+- waitress core developers
+```
diff --git a/docs/conf.py b/docs/conf.py
index aa9b3fb..41fd08e 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -18,6 +18,7 @@
#sys.path.append(os.path.abspath('some/directory'))
import sys, os
+import datetime
import pkg_resources
import pylons_sphinx_themes
@@ -41,7 +42,8 @@ master_doc = 'index'
# General substitutions.
project = 'waitress'
-copyright = '2012, Agendaless Consulting <chrism@plope.com>'
+thisyear = datetime.datetime.now().year
+copyright = '2012-%s, Agendaless Consulting <chrism@plope.com>' % thisyear
# The default replacements for |version| and |release|, also used in various
# other places throughout the built documents.
@@ -91,7 +93,7 @@ pygments_style = 'sphinx'
# Add and use Pylons theme
html_theme = 'pylons'
html_theme_path = pylons_sphinx_themes.get_html_themes_path()
-html_theme_options = dict(github_url='http://github.com/Pylons/waitress')
+html_theme_options = dict(github_url='https://github.com/Pylons/waitress')
# The style sheet to use for HTML and HTML Help pages. A file of that name
# must exist either in Sphinx' static/ path, or in one of the custom paths
@@ -175,7 +177,7 @@ htmlhelp_basename = 'atemplatedoc'
# author, document class [howto/manual]).
latex_documents = [
('index', 'waitress.tex', 'waitress Documentation',
- 'Pylons Developers', 'manual'),
+ 'Pylons Project Developers', 'manual'),
]
# The name of an image file (relative to this directory) to place at the