summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <xistence@0x58.com>2018-05-20 14:35:20 -0600
committerGitHub <noreply@github.com>2018-05-20 14:35:20 -0600
commitb0e6bc0c6d608227fc64ed3048f5d25657d5bf67 (patch)
tree0594944be9975f2c0f0e3c7cfadfe6475040b0f5
parent04251057e515b2f64e88430c2da1248ee5546519 (diff)
parent11d26f5102162ec02c890aafc3c78f19ce3a6025 (diff)
downloadwaitress-b0e6bc0c6d608227fc64ed3048f5d25657d5bf67.tar.gz
Merge pull request #192 from stevepiercy/master
Remove py33, add py37 allowed failure, for tox and Travis
-rw-r--r--.travis.yml5
-rw-r--r--README.rst24
-rw-r--r--setup.py2
-rw-r--r--tox.ini4
4 files changed, 27 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 401f191..2fc8d4c 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,14 +6,14 @@ matrix:
include:
- python: 2.7
env: TOXENV=py27
- - python: 3.3
- env: TOXENV=py33
- python: 3.4
env: TOXENV=py34
- python: 3.5
env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
+ - python: nightly
+ env: TOXENV=py37
- python: pypy
env: TOXENV=pypy
- python: pypy3
@@ -24,6 +24,7 @@ matrix:
env: TOXENV=docs
allow_failures:
- env: TOXENV=pypy3
+ - env: TOXENV=py37
install:
- travis_retry pip install tox
diff --git a/README.rst b/README.rst
index ce9ea01..1a7b893 100644
--- a/README.rst
+++ b/README.rst
@@ -1,8 +1,26 @@
+Waitress
+========
+
+.. image:: https://img.shields.io/pypi/v/waitress.svg
+ :target: https://pypi.org/project/waitress/
+ :alt: latest version of waitress on PyPI
+
+.. image:: https://travis-ci.org/Pylons/waitress.png?branch=master
+ :target: https://travis-ci.org/Pylons/waitress
+ :alt: Travis CI for waitress (master branch)
+
+.. image:: https://readthedocs.org/projects/waitress/badge/?version=master
+ :target: https://docs.pylonsproject.org/projects/waitress/en/master
+ :alt: master Documentation Status
+
+.. image:: https://img.shields.io/badge/irc-freenode-blue.svg
+ :target: https://webchat.freenode.net/?channels=pyramid
+ :alt: IRC Freenode
+
Waitress is meant to be a production-quality pure-Python WSGI server with very
acceptable performance. It has no dependencies except ones which live in the
Python standard library. It runs on CPython on Unix and Windows under Python
-2.7+ and Python 3.3+. It is also known to run on PyPy 1.6.0+ on UNIX. It
+2.7+ and Python 3.4+. It is also known to run on PyPy 1.6.0+ on UNIX. It
supports HTTP/1.0 and HTTP/1.1.
-For more information, see the "docs" directory of the Waitress package or
-http://docs.pylonsproject.org/projects/waitress/en/latest/ .
+For more information, see the "docs" directory of the Waitress package or visit https://docs.pylonsproject.org/projects/waitress/en/latest/
diff --git a/setup.py b/setup.py
index 3bda37d..8c15107 100644
--- a/setup.py
+++ b/setup.py
@@ -52,7 +52,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
@@ -61,6 +60,7 @@ setup(
'Natural Language :: English',
'Operating System :: OS Independent',
'Topic :: Internet :: WWW/HTTP',
+ "Topic :: Internet :: WWW/HTTP :: WSGI",
],
url='https://github.com/Pylons/waitress',
packages=find_packages(),
diff --git a/tox.ini b/tox.ini
index 3dd9921..b9873c6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py27,py33,py34,py35,py36,pypy,
+ py27,py34,py35,py36,pypy,
docs,
{py2,py3}-cover,coverage
@@ -9,10 +9,10 @@ envlist =
# to defaults for others.
basepython =
py27: python2.7
- py33: python3.3
py34: python3.4
py35: python3.5
py36: python3.6
+ py37: python3.7
pypy: pypy
py2: python2.7
py3: python3.5