summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2020-02-02 22:54:07 -0800
committerBert JW Regeer <bertjw@regeer.org>2020-04-16 22:54:29 -0700
commite2facc893269d8a7492ae23ed047fb50b71ccd6b (patch)
tree0115e17805376482a59ba06265897eb6761296af
parent1b1dac068b7f6bd74aa0002e800e95acb0fbe3c8 (diff)
downloadwaitress-e2facc893269d8a7492ae23ed047fb50b71ccd6b.tar.gz
Move from setup.py to setup.cfg
-rw-r--r--setup.cfg61
-rw-r--r--setup.py80
2 files changed, 58 insertions, 83 deletions
diff --git a/setup.cfg b/setup.cfg
index 81cfbb1..ac1ceb8 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,58 @@
-[easy_install]
-zip_ok = false
+[metadata]
+name = waitress
+version = 1.4.4a0
+description = Waitress WSGI server
+long_description = file: README.rst, CHANGES.txt
+long_description_content_type = text/x-rst
+keywords = waitress wsgi server http
+license = ZPL 2.1
+classifiers =
+ Development Status :: 6 - Mature
+ Environment :: Web Environment
+ Intended Audience :: Developers
+ License :: OSI Approved :: Zope Public License
+ Programming Language :: Python
+ Programming Language :: Python :: 2
+ Programming Language :: Python :: 2.7
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: Implementation :: CPython
+ Programming Language :: Python :: Implementation :: PyPy
+ Operating System :: OS Independent
+ Topic :: Internet :: WWW/HTTP
+ Topic :: Internet :: WWW/HTTP :: WSGI
+url = https://github.com/Pylons/waitress
+author = Zope Foundation and Contributors
+author_email = zope-dev@zope.org
+maintainer = Pylons Project
+maintainer_email = pylons-discuss@googlegroups.com
+
+[options]
+package_dir=
+ =src
+packages=find:
+python_requires = >=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*
+
+[options.entry_points]
+paste.server_runner =
+ main = waitress:serve_paste
+console_scripts =
+ waitress-serve = waitress.runner:run
+
+[options.packages.find]
+where=src
+
+[options.extras_require]
+testing =
+ nose
+ coverage>=5.0
+
+docs =
+ Sphinx>=1.8.1
+ docutils
+ pylons-sphinx-themes>=1.0.9
[nosetests]
match=^test
@@ -10,6 +63,4 @@ cover-erase=1
[bdist_wheel]
universal = 1
-[aliases]
-dev = develop easy_install waitress[testing]
-docs = develop easy_install waitress[docs]
+
diff --git a/setup.py b/setup.py
index 0468a82..6068493 100644
--- a/setup.py
+++ b/setup.py
@@ -1,79 +1,3 @@
-##############################################################################
-#
-# Copyright (c) 2006 Zope Foundation and Contributors.
-# All Rights Reserved.
-#
-# This software is subject to the provisions of the Zope Public License,
-# Version 2.1 (ZPL). A copy of the ZPL should accompany this distribution.
-# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY AND ALL EXPRESS OR IMPLIED
-# WARRANTIES ARE DISCLAIMED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF TITLE, MERCHANTABILITY, AGAINST INFRINGEMENT, AND FITNESS
-# FOR A PARTICULAR PURPOSE.
-#
-##############################################################################
-import os
+from setuptools import setup
-from setuptools import find_packages, setup
-
-here = os.path.abspath(os.path.dirname(__file__))
-try:
- README = open(os.path.join(here, "README.rst")).read()
- CHANGES = open(os.path.join(here, "CHANGES.txt")).read()
-except IOError:
- README = CHANGES = ""
-
-docs_extras = [
- "Sphinx>=1.8.1",
- "docutils",
- "pylons-sphinx-themes>=1.0.9",
-]
-
-testing_extras = [
- "nose",
- "coverage>=5.0",
-]
-
-setup(
- name="waitress",
- version="1.4.3",
- author="Zope Foundation and Contributors",
- author_email="zope-dev@zope.org",
- maintainer="Pylons Project",
- maintainer_email="pylons-discuss@googlegroups.com",
- description="Waitress WSGI server",
- long_description=README + "\n\n" + CHANGES,
- license="ZPL 2.1",
- keywords="waitress wsgi server http",
- classifiers=[
- "Development Status :: 5 - Production/Stable",
- "Environment :: Web Environment",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: Zope Public License",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: Implementation :: CPython",
- "Programming Language :: Python :: Implementation :: PyPy",
- "Natural Language :: English",
- "Operating System :: OS Independent",
- "Topic :: Internet :: WWW/HTTP",
- "Topic :: Internet :: WWW/HTTP :: WSGI",
- ],
- url="https://github.com/Pylons/waitress",
- packages=find_packages(),
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",
- extras_require={"testing": testing_extras, "docs": docs_extras},
- include_package_data=True,
- test_suite="waitress",
- zip_safe=False,
- entry_points="""
- [paste.server_runner]
- main = waitress:serve_paste
- [console_scripts]
- waitress-serve = waitress.runner:run
- """,
-)
+setup()