summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris McDonough <chrism@plope.com>2014-07-13 22:05:29 -0400
committerChris McDonough <chrism@plope.com>2014-07-13 22:05:29 -0400
commit0feff7a68245a23a721d17239d80ad85fd12b1ca (patch)
tree0383128f3e1f79c17cc972205e55fd7666f74a6a
parentd9eb9db28b8847842d0b9f5e3de3b2345f3b1ee4 (diff)
downloadwaitress-0feff7a68245a23a721d17239d80ad85fd12b1ca.tar.gz
Add a ``docs`` section to tox.ini that, when run, ensures docs can be built.
-rw-r--r--tox.ini12
1 files changed, 11 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 4d14b3f..6e71b10 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,py33,pypy,cover
+ py26,py27,py32,py33,pypy,cover,docs
[testenv]
commands =
@@ -15,3 +15,13 @@ commands =
python setup.py nosetests --with-xunit --with-xcoverage
deps =
nosexcover
+
+[testenv:docs]
+basepython =
+ python2.7
+commands =
+ python setup.py dev
+ sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
+deps =
+ Sphinx
+ repoze.sphinx.autointerface