summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2014-12-18 21:35:56 -0500
committerTres Seaver <tseaver@palladion.com>2014-12-18 21:35:56 -0500
commit3f7dc9891d8b592e483c79f9b87badb9cd5e719e (patch)
treee27409982f6d6e4d1cc08799bb4343b1ee0d2d9d
parentfaa63fdc480319d17b89cd302bc7cc5dc863970d (diff)
downloadwaitress-3f7dc9891d8b592e483c79f9b87badb9cd5e719e.tar.gz
Add support for Python 3.4, PyPy3.
-rw-r--r--CHANGES.txt2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 1 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 6d5e7c1..f128d9b 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,6 +1,8 @@
Next release
------------
+- Add support for Python 3.4 and PyPy3.
+
- Use a nonglobal asyncore socket map by default to hopefully prevent conflicts
with apps and libs that use the asyncore global socket map ala
https://github.com/Pylons/waitress/issues/63. You can get the old
diff --git a/setup.py b/setup.py
index 33c5963..9d48433 100644
--- a/setup.py
+++ b/setup.py
@@ -58,6 +58,7 @@ setup(
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
'Natural Language :: English',
diff --git a/tox.ini b/tox.ini
index 6e71b10..f048ea0 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py32,py33,pypy,cover,docs
+ py26,py27,pypy,py32,py33,py34,pypy3,cover,docs
[testenv]
commands =