summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2020-04-16 22:56:26 -0700
committerBert JW Regeer <bertjw@regeer.org>2020-04-16 22:59:07 -0700
commita2962aed85e5dbe1688a93b2f7f76202cd395eb3 (patch)
tree212c3729fbd577cd1f526a906fc8a066a630cabc
parentc141ba2b938633548a79bb7174f91572d710f38c (diff)
downloadwaitress-a2962aed85e5dbe1688a93b2f7f76202cd395eb3.tar.gz
Remove travis and appveyor from this repo
-rw-r--r--.travis.yml47
-rw-r--r--MANIFEST.in2
-rw-r--r--appveyor.yml27
3 files changed, 1 insertions, 75 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 464fd86..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,47 +0,0 @@
-# Wire up travis
-language: python
-sudo: false
-
-matrix:
- include:
- - python: 2.7
- env: TOXENV=py27
- - python: 3.5
- env: TOXENV=py35
- - python: 3.6
- env: TOXENV=py36
- - python: 3.7
- env: TOXENV=py37
- dist: xenial
- sudo: true
- - python: 3.8
- env: TOXENV=py38
- dist: xenial
- sudo: true
- - python: pypy
- env: TOXENV=pypy
- - python: pypy3
- env: TOXENV=pypy3
- - python: 3.8
- env: TOXENV=py27,py38,coverage
- dist: xenial
- sudo: true
- - python: 3.8
- env: TOXENV=lint
- dist: xenial
- sudo: true
- - python: 3.5
- env: TOXENV=docs
-
-install:
- - travis_retry pip install tox
-
-script:
- - travis_retry tox
-
-notifications:
- email:
- - pyramid-checkins@lists.repoze.org
- irc:
- channels:
- - "chat.freenode.net#pyramid"
diff --git a/MANIFEST.in b/MANIFEST.in
index b52891d..7540038 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -14,7 +14,7 @@ include COPYRIGHT.txt
include pyproject.toml setup.cfg
include .coveragerc .flake8
-include tox.ini .travis.yml rtd.txt appveyor.yml
+include tox.ini rtd.txt
exclude TODO.txt
diff --git a/appveyor.yml b/appveyor.yml
deleted file mode 100644
index 48cb759..0000000
--- a/appveyor.yml
+++ /dev/null
@@ -1,27 +0,0 @@
-environment:
- matrix:
- - PYTHON: "C:\\Python27"
- TOXENV: "py27"
- - PYTHON: "C:\\Python27-x64"
- TOXENV: "py27"
- - PYTHON: "C:\\Python36"
- TOXENV: "py36"
- - PYTHON: "C:\\Python36-x64"
- TOXENV: "py36"
- - PYTHON: "C:\\Python37"
- TOXENV: "py37"
- - PYTHON: "C:\\Python37-x64"
- TOXENV: "py37"
-
-cache:
- - '%LOCALAPPDATA%\pip\Cache'
-
-version: '{branch}.{build}'
-
-install:
- - "%PYTHON%\\python.exe -m pip install tox"
-
-build: off
-
-test_script:
- - "%PYTHON%\\Scripts\\tox.exe"