summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2020-05-07 00:06:26 -0700
committerBert JW Regeer <bertjw@regeer.org>2020-08-15 18:55:01 -0700
commitdc1f15a62144974f06127c5dfe32b58eeb528efc (patch)
tree08ccc798d07fffb3819ba2f622d9b250a4da067a
parent0c29f02fd44314f454f7eb051ccfb7ff0933c97c (diff)
downloadwaitress-dc1f15a62144974f06127c5dfe32b58eeb528efc.tar.gz
Drop Python 2.7 support officially
-rw-r--r--.github/workflows/ci-tests.yml8
-rw-r--r--CHANGES.txt5
-rw-r--r--README.rst13
-rw-r--r--pyproject.toml2
-rw-r--r--setup.cfg4
-rw-r--r--tox.ini3
6 files changed, 16 insertions, 19 deletions
diff --git a/.github/workflows/ci-tests.yml b/.github/workflows/ci-tests.yml
index 54b229e..c8c660e 100644
--- a/.github/workflows/ci-tests.yml
+++ b/.github/workflows/ci-tests.yml
@@ -15,7 +15,6 @@ jobs:
strategy:
matrix:
py:
- - "2.7"
- "3.5"
- "3.6"
- "3.7"
@@ -56,11 +55,6 @@ jobs:
name: Validate coverage
steps:
- uses: actions/checkout@v2
- - name: Setup python 2.7
- uses: actions/setup-python@v2
- with:
- python-version: 2.7
- architecture: x64
- name: Setup python 3.8
uses: actions/setup-python@v2
with:
@@ -68,7 +62,7 @@ jobs:
architecture: x64
- run: pip install tox
- - run: tox -e py38,py27,coverage
+ - run: tox -e py38,coverage
docs:
runs-on: ubuntu-latest
name: Build the documentation
diff --git a/CHANGES.txt b/CHANGES.txt
index 5550995..f4d1acc 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,8 @@
+2.0.0 (unreleased)
+------------------
+
+- Drop Python 2.7 support
+
1.4.4 (2020-06-01)
------------------
diff --git a/README.rst b/README.rst
index f9bf1a8..b85e49d 100644
--- a/README.rst
+++ b/README.rst
@@ -16,10 +16,11 @@ Waitress
:target: https://webchat.freenode.net/?channels=pyramid
:alt: IRC Freenode
-Waitress is meant to be a production-quality pure-Python WSGI server with very
-acceptable performance. It has no dependencies except ones which live in the
-Python standard library. It runs on CPython on Unix and Windows under Python
-2.7+ and Python 3.5+. It is also known to run on PyPy 1.6.0+ on UNIX. It
-supports HTTP/1.0 and HTTP/1.1.
+Waitress is a production-quality pure-Python WSGI server with very acceptable
+performance. It has no dependencies except ones which live in the Python
+standard library. It runs on CPython on Unix and Windows under Python 3.5+. It
+is also known to run on PyPy (version 3.5 compatible) on UNIX. It supports
+HTTP/1.0 and HTTP/1.1.
-For more information, see the "docs" directory of the Waitress package or visit https://docs.pylonsproject.org/projects/waitress/en/latest/
+For more information, see the "docs" directory of the Waitress package or visit
+https://docs.pylonsproject.org/projects/waitress/en/latest/
diff --git a/pyproject.toml b/pyproject.toml
index 7f50ece..1bc058b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,7 +3,7 @@ requires = ["setuptools >= 41"]
build-backend = "setuptools.build_meta"
[tool.black]
-py36 = false
+target-version = ['py35', 'py36', 'py37', 'py38']
exclude = '''
/(
\.git
diff --git a/setup.cfg b/setup.cfg
index a10b6a1..d7c1c73 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -12,8 +12,6 @@ classifiers =
Intended Audience :: Developers
License :: OSI Approved :: Zope Public License
Programming Language :: Python
- Programming Language :: Python :: 2
- Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
@@ -39,7 +37,7 @@ maintainer_email = pylons-discuss@googlegroups.com
package_dir=
=src
packages=find:
-python_requires = >=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*
+python_requires = >=3.5.0
[options.entry_points]
paste.server_runner =
diff --git a/tox.ini b/tox.ini
index 6ca71ad..2040825 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,6 @@
[tox]
envlist =
lint,
- py27,pypy,
py35,py36,py37,py38,pypy3,
docs,
coverage
@@ -26,7 +25,7 @@ deps =
coverage
setenv =
COVERAGE_FILE=.coverage
-depends = py27, py38
+depends = py38
[testenv:lint]
skip_install = True