summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2019-12-12 11:45:25 -0800
committerBert JW Regeer <bertjw@regeer.org>2019-12-12 11:45:25 -0800
commit0a05a2f5932d87e5f4e150edc00b4e9a62c87791 (patch)
treeb721e9d73c601033fe0c465dd68ad87795b81301 /setup.py
parent0b3e3cf815050c40cf13998150f21bc63212c65e (diff)
downloadwaitress-0a05a2f5932d87e5f4e150edc00b4e9a62c87791.tar.gz
Blacken the entire code base
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py79
1 files changed, 38 insertions, 41 deletions
diff --git a/setup.py b/setup.py
index 9a07479..13a9d58 100644
--- a/setup.py
+++ b/setup.py
@@ -16,66 +16,63 @@ from setuptools import setup, find_packages
here = os.path.abspath(os.path.dirname(__file__))
try:
- README = open(os.path.join(here, 'README.rst')).read()
- CHANGES = open(os.path.join(here, 'CHANGES.txt')).read()
+ README = open(os.path.join(here, "README.rst")).read()
+ CHANGES = open(os.path.join(here, "CHANGES.txt")).read()
except IOError:
- README = CHANGES = ''
+ README = CHANGES = ""
docs_extras = [
- 'Sphinx>=1.8.1',
- 'docutils',
- 'pylons-sphinx-themes>=1.0.9',
+ "Sphinx>=1.8.1",
+ "docutils",
+ "pylons-sphinx-themes>=1.0.9",
]
testing_extras = [
- 'nose',
- 'coverage',
+ "nose",
+ "coverage",
]
setup(
- name='waitress',
- version='1.3.1',
- author='Zope Foundation and Contributors',
- author_email='zope-dev@zope.org',
+ name="waitress",
+ version="1.3.1",
+ author="Zope Foundation and Contributors",
+ author_email="zope-dev@zope.org",
maintainer="Pylons Project",
maintainer_email="pylons-discuss@googlegroups.com",
- description='Waitress WSGI server',
- long_description=README + '\n\n' + CHANGES,
- license='ZPL 2.1',
- keywords='waitress wsgi server http',
+ description="Waitress WSGI server",
+ long_description=README + "\n\n" + CHANGES,
+ license="ZPL 2.1",
+ keywords="waitress wsgi server http",
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Zope Public License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Natural Language :: English',
- 'Operating System :: OS Independent',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Zope Public License",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Natural Language :: English",
+ "Operating System :: OS Independent",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: WSGI",
],
- url='https://github.com/Pylons/waitress',
+ url="https://github.com/Pylons/waitress",
packages=find_packages(),
- extras_require={
- 'testing': testing_extras,
- 'docs': docs_extras,
- },
+ extras_require={"testing": testing_extras, "docs": docs_extras,},
include_package_data=True,
- test_suite='waitress',
+ test_suite="waitress",
zip_safe=False,
entry_points="""
[paste.server_runner]
main = waitress:serve_paste
[console_scripts]
waitress-serve = waitress.runner:run
- """
+ """,
)