diff options
author | Chris McDonough <chrism@plope.com> | 2011-12-28 08:57:21 -0500 |
---|---|---|
committer | Chris McDonough <chrism@plope.com> | 2011-12-28 08:57:21 -0500 |
commit | fec87bdc035b98a4fe7b42473fb83ba5e14a823f (patch) | |
tree | 6ea4c75ff7bb7369f67b5c649004d5e3039e6969 /setup.py | |
parent | 08bc0ff4bfbafa8175b7432f81581b7efdc4b1d1 (diff) | |
download | waitress-fec87bdc035b98a4fe7b42473fb83ba5e14a823f.tar.gz |
do this stupid dance for jenkins
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 7 insertions, 7 deletions
@@ -14,8 +14,12 @@ import os from setuptools import setup, find_packages -def read(*rnames): - return open(os.path.join(os.path.dirname(__file__), *rnames)).read() +here = os.path.abspath(os.path.dirname(__file__)) +try: + README = open(os.path.join(here, 'README.rst')).read() + CHANGES = open(os.path.join(here, 'CHANGES.txt')).read() +except IOError: + README = CHANGES = '' setup( name='waitress', @@ -25,11 +29,7 @@ setup( maintainer="Chris McDonough", maintainer_email="chrism@plope.com", description='Waitress WSGI server', - long_description=( - read('README.rst') - + '\n\n' + - read('CHANGES.txt') - ), + long_description = README +'\n\n' + CHANGES, license='ZPL 2.1', keywords='waitress wsgi server http', classifiers = [ |