summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2020-02-02 16:38:23 -0800
committerBert JW Regeer <bertjw@regeer.org>2020-02-02 21:54:01 -0800
commit3db639fee74a10524e6908318f3f8f6e7c545e9b (patch)
treec4f491d7c9afa0ff7025df6f0236cbf0189b5cc4 /setup.py
parentcbc89bf742ef7cbca17671ec9acd3898491c378f (diff)
downloadwaitress-3db639fee74a10524e6908318f3f8f6e7c545e9b.tar.gz
Drop Python 3.4
This is necessary due to needing coverage>=5.0, which is no longer available on Python 3.4. Python 3.4 is also now past end of life. This continued to work by chance due to Travis having nosetest installed in the Python global installation, and thus the failure from tox to install coverage>=5.0 did not cause errors on Travis. Testing locally I still had an old version of coverage installed, and that version had not yet dropped Python 3.4.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 44da229..0468a82 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,8 @@
#
##############################################################################
import os
-from setuptools import setup, find_packages
+
+from setuptools import find_packages, setup
here = os.path.abspath(os.path.dirname(__file__))
try:
@@ -52,7 +53,6 @@ setup(
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
@@ -65,7 +65,8 @@ setup(
],
url="https://github.com/Pylons/waitress",
packages=find_packages(),
- extras_require={"testing": testing_extras, "docs": docs_extras,},
+ python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*",
+ extras_require={"testing": testing_extras, "docs": docs_extras},
include_package_data=True,
test_suite="waitress",
zip_safe=False,