summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2016-11-18 16:58:30 -0700
committerBert JW Regeer <bertjw@regeer.org>2016-11-18 16:58:30 -0700
commit36683655d24f2c9a82e2d07a713dcac3ffce15aa (patch)
tree694aab515b0d72bc9c61262156ab562224d76e71
parent91294c62ae5484f64e1d7857459ca895e0ca2740 (diff)
downloadwebob-36683655d24f2c9a82e2d07a713dcac3ffce15aa.tar.gz
Back to dev for WebOb
-rw-r--r--CHANGES.txt104
-rw-r--r--HISTORY.txt109
-rw-r--r--setup.py2
3 files changed, 110 insertions, 105 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 17003c1..393cd8d 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,108 +1,4 @@
Unreleased
----------
-Compatibility
-~~~~~~~~~~~~~
-- WebOb is no longer supported on Python 2.6 and PyPy3 (due to pip no longer
- supporting Python 3.2 even on PyPy)
-
-Backwards Incompatibility
-~~~~~~~~~~~~~~~~~~~~~~~~~
-
-- Response.set_cookie no longer accepts a key argument. This was deprecated in
- WebOb 1.5 and as mentioned in the deprecation, is being removed in 1.7
-
-- Response `__init__` will no longer set the default Content-Type, nor
- Content-Length on Responses that don't have a body. This allows WebOb to
- return proper responses for things like `Response(status='204 No Content')`.
-
-- Response.text will no longer raise if the Content-Type does not have a
- charset, it will fall back to using the new default_body_encoding. To get the
- old behaviour back please sub-class Response and set default_body_encoding to
- None. See https://github.com/Pylons/webob/pull/287
-
-- WebOb no longer supports Chunked Encoding, this means that if you are using
- WebOb and need Chunked Encoding you will be required to have a proxy that
- unchunks the request for you. Please read
- https://github.com/Pylons/webob/issues/279 for more background.
-
-Feature
-~~~~~~~
-
-- Response has a new default_body_encoding which may be used to allow
- getting/setting Response.text when a Content-Type has no charset. See
- https://github.com/Pylons/webob/pull/287
-
-- webob.Request with any HTTP method is now allowed to have a body. This allows
- DELETE to have a request body for passing extra information. See
- https://github.com/Pylons/webob/pull/283 and
- https://github.com/Pylons/webob/pull/274
-
-- Add `tell()` to `ResponseBodyFile` so that it may be used for example for
- ZipFile support. See https://github.com/Pylons/webob/pull/117
-
-- Allow the return from `wsgify.middleware` to be used as a decorator. See
- https://github.com/Pylons/webob/pull/228
-
-Bugfix
-~~~~~~
-
-- Fixup cgi.FieldStorage on Python 3.x to work-around issue reported in Python
- bug report 27777 and 24764. This is currently applied for Python versions
- less than 3.7. See https://github.com/Pylons/webob/pull/294
-
-- Response.set_cookie now accepts datetime objects for the expire kwarg and
- will correctly convert them to UTC with no tzinfo for use in calculating the
- max_age. See https://github.com/Pylons/webob/issues/254 and
- https://github.com/Pylons/webob/pull/292
-
-- Fixes request.PATH_SAFE to contain all of the path safe characters according
- to RFC3986. See https://github.com/Pylons/webob/pull/291
-
-- WebOb's exceptions will lazily read underlying variables when inserted into
- templates to avoid expensive computations/crashes when inserting into the
- template. This had a bad performance regression on Py27 because of the way
- the lazified class was created and returned. See
- https://github.com/Pylons/webob/pull/284
-
-- `wsgify.__call__` raised a `TypeError` with an unhelpful message, it will now
- return the `repr` for the wrapped function:
- https://github.com/Pylons/webob/issues/119
-
-- Response.content_type removes the charset content_type parameters unless the
- new content_type is a text like type that has a charset parameter.
- See https://github.com/Pylons/webob/pull/261 and
- https://github.com/Pylons/webob/issues/130
-
-- Response.json's json.dumps/loads are now always UTF-8. It no longer tries to
- use the charset.
-
-- Response `__init__` will no longer set the default Content-Type, nor
- Content-Length on Responses that don't have a body. This allows WebOb to
- return proper responses for things like `Response(status='204 No Content')`.
-
-- The Response `__init__` will by default no longer set the Content-Type to the
- default if a headerlist is provided. This fixes issues whereby
- `Request.get_response()` would return a Response that didn't match the actual
- response.
- See https://github.com/Pylons/webob/pull/261 and
- https://github.com/Pylons/webob/issues/205
-
-- Cleans up the remainder of the issues with the updated WebOb exceptions that
- were taught to return JSON in version 1.6. See
- https://github.com/Pylons/webob/issues/237 and
- https://github.com/Pylons/webob/issues/236
-
-- Response.from_file now parses the status line correctly when the status line
- contains an HTTP with version, as well as a status text that contains
- multiple white spaces (e.g HTTP/1.1 404 Not Found). See
- https://github.com/Pylons/webob/issues/250
-
-- Response now has a new property named `has_body` that may be used to
- interrogate the Response to find out if `Response.body` is or isn't set.
-
- This is used in the exception handling code so that if you use a WebOb HTTP
- Exception and pass a generator to `app_iter` WebOb won't attempt to read the
- whole thing and instead allows it to be returned to the WSGI server. See
- https://github.com/Pylons/webob/pull/259
diff --git a/HISTORY.txt b/HISTORY.txt
index a5313b7..a54e403 100644
--- a/HISTORY.txt
+++ b/HISTORY.txt
@@ -1,3 +1,112 @@
+1.7.0rc1 (2016-11-18)
+---------------------
+
+Compatibility
+~~~~~~~~~~~~~
+
+- WebOb is no longer supported on Python 2.6 and PyPy3 (due to pip no longer
+ supporting Python 3.2 even on PyPy)
+
+Backwards Incompatibility
+~~~~~~~~~~~~~~~~~~~~~~~~~
+
+- Response.set_cookie no longer accepts a key argument. This was deprecated in
+ WebOb 1.5 and as mentioned in the deprecation, is being removed in 1.7
+
+- Response `__init__` will no longer set the default Content-Type, nor
+ Content-Length on Responses that don't have a body. This allows WebOb to
+ return proper responses for things like `Response(status='204 No Content')`.
+
+- Response.text will no longer raise if the Content-Type does not have a
+ charset, it will fall back to using the new default_body_encoding. To get the
+ old behaviour back please sub-class Response and set default_body_encoding to
+ None. See https://github.com/Pylons/webob/pull/287
+
+- WebOb no longer supports Chunked Encoding, this means that if you are using
+ WebOb and need Chunked Encoding you will be required to have a proxy that
+ unchunks the request for you. Please read
+ https://github.com/Pylons/webob/issues/279 for more background.
+
+Feature
+~~~~~~~
+
+- Response has a new default_body_encoding which may be used to allow
+ getting/setting Response.text when a Content-Type has no charset. See
+ https://github.com/Pylons/webob/pull/287
+
+- webob.Request with any HTTP method is now allowed to have a body. This allows
+ DELETE to have a request body for passing extra information. See
+ https://github.com/Pylons/webob/pull/283 and
+ https://github.com/Pylons/webob/pull/274
+
+- Add `tell()` to `ResponseBodyFile` so that it may be used for example for
+ ZipFile support. See https://github.com/Pylons/webob/pull/117
+
+- Allow the return from `wsgify.middleware` to be used as a decorator. See
+ https://github.com/Pylons/webob/pull/228
+
+Bugfix
+~~~~~~
+
+- Fixup cgi.FieldStorage on Python 3.x to work-around issue reported in Python
+ bug report 27777 and 24764. This is currently applied for Python versions
+ less than 3.7. See https://github.com/Pylons/webob/pull/294
+
+- Response.set_cookie now accepts datetime objects for the expire kwarg and
+ will correctly convert them to UTC with no tzinfo for use in calculating the
+ max_age. See https://github.com/Pylons/webob/issues/254 and
+ https://github.com/Pylons/webob/pull/292
+
+- Fixes request.PATH_SAFE to contain all of the path safe characters according
+ to RFC3986. See https://github.com/Pylons/webob/pull/291
+
+- WebOb's exceptions will lazily read underlying variables when inserted into
+ templates to avoid expensive computations/crashes when inserting into the
+ template. This had a bad performance regression on Py27 because of the way
+ the lazified class was created and returned. See
+ https://github.com/Pylons/webob/pull/284
+
+- `wsgify.__call__` raised a `TypeError` with an unhelpful message, it will now
+ return the `repr` for the wrapped function:
+ https://github.com/Pylons/webob/issues/119
+
+- Response.content_type removes the charset content_type parameters unless the
+ new content_type is a text like type that has a charset parameter.
+ See https://github.com/Pylons/webob/pull/261 and
+ https://github.com/Pylons/webob/issues/130
+
+- Response.json's json.dumps/loads are now always UTF-8. It no longer tries to
+ use the charset.
+
+- Response `__init__` will no longer set the default Content-Type, nor
+ Content-Length on Responses that don't have a body. This allows WebOb to
+ return proper responses for things like `Response(status='204 No Content')`.
+
+- The Response `__init__` will by default no longer set the Content-Type to the
+ default if a headerlist is provided. This fixes issues whereby
+ `Request.get_response()` would return a Response that didn't match the actual
+ response.
+ See https://github.com/Pylons/webob/pull/261 and
+ https://github.com/Pylons/webob/issues/205
+
+- Cleans up the remainder of the issues with the updated WebOb exceptions that
+ were taught to return JSON in version 1.6. See
+ https://github.com/Pylons/webob/issues/237 and
+ https://github.com/Pylons/webob/issues/236
+
+- Response.from_file now parses the status line correctly when the status line
+ contains an HTTP with version, as well as a status text that contains
+ multiple white spaces (e.g HTTP/1.1 404 Not Found). See
+ https://github.com/Pylons/webob/issues/250
+
+- Response now has a new property named `has_body` that may be used to
+ interrogate the Response to find out if `Response.body` is or isn't set.
+
+ This is used in the exception handling code so that if you use a WebOb HTTP
+ Exception and pass a generator to `app_iter` WebOb won't attempt to read the
+ whole thing and instead allows it to be returned to the WSGI server. See
+ https://github.com/Pylons/webob/pull/259
+
1.6.0 (2016-03-15)
------------------
diff --git a/setup.py b/setup.py
index 52c81af..a1418c5 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ docs_extras = [
setup(
name='WebOb',
- version='1.7.0dev0',
+ version='1.8.0dev0',
description="WSGI request and response object",
long_description=README + '\n\n' + CHANGES,
classifiers=[