diff options
author | Daniel Holth <dholth@fastmail.fm> | 2014-03-26 22:54:32 -0400 |
---|---|---|
committer | Daniel Holth <dholth@fastmail.fm> | 2014-03-26 22:54:32 -0400 |
commit | f3c89f616f59ae69cbae917a461085241133e522 (patch) | |
tree | 4158336eb51ca83154d8e8d42a66b3103cea784f | |
parent | 5862302828ec5fdbbf2c3eacb2113b7c5c3d2eca (diff) | |
download | wheel-f3c89f616f59ae69cbae917a461085241133e522.tar.gz |
replace dirspec with pyxdg (hosted on pypi); bump version to 0.23.0
-rw-r--r-- | setup.cfg | 6 | ||||
-rw-r--r-- | setup.py | 12 | ||||
-rw-r--r-- | tox.ini | 2 | ||||
-rw-r--r-- | wheel/__init__.py | 2 | ||||
-rw-r--r-- | wheel/util.py | 10 |
5 files changed, 16 insertions, 16 deletions
@@ -2,14 +2,14 @@ addopts=--ignore=dist --ignore=build --cov=wheel [metadata] -provides-extra = +provides-extra = tool signatures faster-signatures -requires-dist = +requires-dist = argparse; python_version == '2.6' keyring; extra == 'signatures' - dirspec; sys.platform != 'win32' and extra == 'signatures' + pyxdg; sys.platform != 'win32' and extra == 'signatures' ed25519ll; extra == 'faster-signatures' license-file = LICENSE.txt @@ -6,7 +6,7 @@ here = os.path.abspath(os.path.dirname(__file__)) README = codecs.open(os.path.join(here, 'README.txt'), encoding='utf8').read() CHANGES = codecs.open(os.path.join(here, 'CHANGES.txt'), encoding='utf8').read() -with codecs.open(os.path.join(os.path.dirname(__file__), 'wheel', '__init__.py'), +with codecs.open(os.path.join(os.path.dirname(__file__), 'wheel', '__init__.py'), encoding='utf8') as version_file: metadata = dict(re.findall(r"""__([a-z]+)__ = "([^"]+)""", version_file.read())) @@ -16,7 +16,7 @@ with codecs.open(os.path.join(os.path.dirname(__file__), 'wheel', '__init__.py') # signature_reqs = ['keyring'] if sys.platform != 'win32': - signature_reqs.append('dirspec') + signature_reqs.append('pyxdg') install_requires = [] if sys.version_info[:2] < (2, 7): install_requires.append('argparse') @@ -42,15 +42,15 @@ setup(name='wheel', keywords=['wheel', 'packaging'], license='MIT', packages=[ - 'wheel', - 'wheel.test', - 'wheel.tool', + 'wheel', + 'wheel.test', + 'wheel.tool', 'wheel.signatures' ], install_requires=install_requires, extras_require={ 'signatures': signature_reqs, - 'faster-signatures': ['ed25519ll'], + 'faster-signatures': ['ed25519ll'], 'tool': [] }, tests_require=['jsonschema', 'pytest', 'coverage', 'pytest-cov'], @@ -15,4 +15,4 @@ deps = pytest pytest-cov wheel[tool,signatures] - distribute>=0.6.34 + setuptools>3.0 diff --git a/wheel/__init__.py b/wheel/__init__.py index 45da823..df7d28d 100644 --- a/wheel/__init__.py +++ b/wheel/__init__.py @@ -1,2 +1,2 @@ # __variables__ with double-quoted values will be available in setup.py: -__version__ = "0.22.0" +__version__ = "0.23.0" diff --git a/wheel/util.py b/wheel/util.py index 93929ad..bc2eb5e 100644 --- a/wheel/util.py +++ b/wheel/util.py @@ -6,7 +6,7 @@ import base64 import json import hashlib -__all__ = ['urlsafe_b64encode', 'urlsafe_b64decode', 'utf8', +__all__ = ['urlsafe_b64encode', 'urlsafe_b64decode', 'utf8', 'to_json', 'from_json', 'matches_requirement'] def urlsafe_b64encode(data): @@ -118,11 +118,11 @@ if sys.platform == 'win32': yield path else: def save_config_path(*resource): - import dirspec.basedir - return dirspec.basedir.save_config_path(*resource) + import xdg.BaseDirectory + return xdg.BaseDirectory.save_config_path(*resource) def load_config_paths(*resource): - import dirspec.basedir - return dirspec.basedir.load_config_paths(*resource) + import xdg.BaseDirectory + return xdg.BaseDirectory.load_config_paths(*resource) def matches_requirement(req, wheels): """List of wheels matching a requirement. |