summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Holth <dholth@fastmail.fm>2013-06-23 14:21:54 -0400
committerDaniel Holth <dholth@fastmail.fm>2013-06-23 14:21:54 -0400
commitd7171781f9c153e20dbb988192d0248e9a8342c5 (patch)
tree09b6cd155cb89764baf164f5d62cc3c9d1d3df54
parent26bc7306641a90a4f5d80ee297522749413bd9e1 (diff)
downloadwheel-d7171781f9c153e20dbb988192d0248e9a8342c5.tar.gz
update test dependencies
-rw-r--r--setup.py2
-rw-r--r--tox.ini9
2 files changed, 5 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 1c05996..a25bc54 100644
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,7 @@ setup(name='wheel',
'faster-signatures': ['ed25519ll'],
'tool': []
},
- tests_require=['jsonschema', 'py.test', 'coverage', 'pytest-cov'],
+ tests_require=['jsonschema', 'pytest', 'coverage', 'pytest-cov'],
include_package_data=True,
zip_safe=False,
entry_points = """\
diff --git a/tox.ini b/tox.ini
index b742af9..0718a84 100644
--- a/tox.ini
+++ b/tox.ini
@@ -8,12 +8,11 @@ envlist = py27, pypy, py32, py33
[testenv]
commands =
- nosetests
+ py.test
deps =
- nose
- markerlib
+ jsonschema
coverage
+ pytest
+ pytest-cov
wheel[tool,signatures]
distribute>=0.6.34
- argparse
- jsonschema