summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Holth <dholth@fastmail.fm>2014-03-26 23:31:40 -0400
committerDaniel Holth <dholth@fastmail.fm>2014-03-26 23:31:40 -0400
commit4ca300562777bef14e7990d113b6fc8d6816a8a2 (patch)
tree6ede2e1cad9aa0b6a2cf1aa3d7338ad0f6d29b90
parenta2e3d94e9f977ab4a9cd0ca502209e9e7861d215 (diff)
downloadwheel-4ca300562777bef14e7990d113b6fc8d6816a8a2.tar.gz
update changes, metadata test
-rw-r--r--CHANGES.txt14
-rw-r--r--wheel/test/test_basic.py6
2 files changed, 14 insertions, 6 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 9564047..a8b1303 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,11 @@
+0.23.0
+======
+- Compatibiltiy tag flags added to the bdist_wheel command
+- sdist should include files necessary for tests
+- 'wheel convert' can now also convert unpacked eggs to wheel
+- Rename pydist.json to metadata.json to avoid stepping on the PEP
+- Thank you contributors
+
0.22.0
======
- Include entry_points.txt, scripts a.k.a. commands, in experimental
@@ -10,7 +18,7 @@
- Pregenerated scripts are the default again.
- "setup.py bdist_wheel --skip-scripts" turns them off.
- setuptools is no longer a listed requirement for the 'wheel'
- package. It is of course still required in order for bdist_wheel
+ package. It is of course still required in order for bdist_wheel
to work.
- "python -m wheel" avoids importing pkg_resources until it's necessary.
@@ -117,8 +125,8 @@
0.9.5
=====
-- Wheel's own wheel file can be executed by Python, and can install itself:
- ``python wheel-0.9.5-py27-none-any/wheel install ...``
+- Wheel's own wheel file can be executed by Python, and can install itself:
+ ``python wheel-0.9.5-py27-none-any/wheel install ...``
- Use argparse; basic ``wheel install`` command should run with only stdlib
dependencies.
- Allow requires_dist in setup.cfg's [metadata] section. In addition to
diff --git a/wheel/test/test_basic.py b/wheel/test/test_basic.py
index 0e88c74..f1fcc6c 100644
--- a/wheel/test/test_basic.py
+++ b/wheel/test/test_basic.py
@@ -94,7 +94,7 @@ def test_unpack():
This also verifies the integrity of our testing wheel files.
"""
for dist in test_distributions:
- distdir = pkg_resources.resource_filename('wheel.test',
+ distdir = pkg_resources.resource_filename('wheel.test',
os.path.join(dist, 'dist'))
for wheelfile in (w for w in os.listdir(distdir) if w.endswith('.whl')):
wheel.tool.unpack(os.path.join(distdir, wheelfile), distdir)
@@ -118,11 +118,11 @@ def test_pydist():
if filename.endswith('.whl'):
whl = ZipFile(os.path.join(dirname, filename))
for entry in whl.infolist():
- if entry.filename.endswith('/pydist.json'):
+ if entry.filename.endswith('/metadata.json'):
pymeta = json.loads(whl.read(entry).decode('utf-8'))
jsonschema.validate(pymeta, pymeta_schema)
valid += 1
- assert valid > 0, "No pydist.json found"
+ assert valid > 0, "No metadata.json found"
def test_util():
"""Test functions in util.py."""