summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/Makefile1
-rw-r--r--doc/conf.py1
-rwxr-xr-xtox.ini2
3 files changed, 3 insertions, 1 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 2070e97..c97ae1c 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -1,5 +1,6 @@
# Minimal makefile for Sphinx documentation
#
+export PATH:=$(PATH):../.tox/py310-sphinx/bin/
# You can set these variables from the command line.
SPHINXOPTS =
diff --git a/doc/conf.py b/doc/conf.py
index 2819070..ef9e4d8 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,6 +48,7 @@ extensions = [
"sphinx.ext.doctest",
"sphinx.ext.intersphinx",
"sphinx.ext.viewcode",
+ "sphinxcontrib.programoutput",
]
# Add any paths that contain templates here, relative to this directory.
diff --git a/tox.ini b/tox.ini
index 2c80fed..f9d9dbc 100755
--- a/tox.ini
+++ b/tox.ini
@@ -15,8 +15,8 @@ commands=pytest []
deps=
hg+http://hg.sr.ht/~olly/fresco-sphinx-theme#egg=fresco_sphinx_theme
sphinx
+ sphinxcontrib-programoutput
{[testenv]deps}
-
commands=
sphinx-build -M doctest "{toxinidir}/doc/" "{toxinidir}_build"