summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-02-17 09:29:39 -0500
committerTres Seaver <tseaver@palladion.com>2016-02-17 09:33:08 -0500
commit5f8a49a6ba3ac9d59c8a3d683ecc254e663417f8 (patch)
tree170c77c7745b9a7bc431d396eca9b1b036e1d155
parent0753f7aefe707ee2941c0ccb925d32edb57dbbec (diff)
downloadzope-event-5f8a49a6ba3ac9d59c8a3d683ecc254e663417f8.tar.gz
Drop Python 2.6 / 3.2 support.
Bump to new minor version due to platform support changes.
-rw-r--r--.travis.yml2
-rw-r--r--CHANGES.rst10
-rw-r--r--setup.py4
-rw-r--r--tox.ini4
4 files changed, 10 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 4f69fb2..4847904 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,9 +1,7 @@
language: python
sudo: false
python:
- - 2.6
- 2.7
- - 3.2
- 3.3
- 3.4
- 3.5
diff --git a/CHANGES.rst b/CHANGES.rst
index 1d6e112..f571031 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,17 +1,21 @@
``zope.event`` Changelog
========================
-4.1.1 (unreleased)
+4.2.0 (unreleased)
------------------
-- Claim support for Python 3.5.
+- Add support for Python 3.5.
+
+- Drop support for Python 2.6 and 3.2.
+
4.1.0 (2015-10-18)
------------------
- Require 100% branch (as well as statement) coverage.
-- Added a simple class-based handler implementation.
+- Add a simple class-based handler implementation.
+
4.0.3 (2014-03-19)
------------------
diff --git a/setup.py b/setup.py
index dbac782..3720f65 100644
--- a/setup.py
+++ b/setup.py
@@ -27,7 +27,7 @@ def read(*rnames):
setup(
name='zope.event',
- version='4.1.1.dev0',
+ version='4.2.0.dev0',
url='http://pypi.python.org/pypi/zope.event',
license='ZPL 2.1',
description='Very basic event publishing system',
@@ -45,10 +45,8 @@ setup(
"Operating System :: OS Independent",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
"Programming Language :: Python :: 3.5",
diff --git a/tox.ini b/tox.ini
index a9268ff..6b186ee 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,8 +3,8 @@ envlist =
# Jython 2.7b1 support pending fix for Jython incompat. w/ pip's vendored-in
# requests -> html5 libraries. See
# https://github.com/html5lib/html5lib-python/pull/150
-# py26,py27,py32,py33,py34,pypy,pypy3,jython,coverage,docs
- py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage,docs
+# py27,py33,py34,pypy,pypy3,jython,coverage,docs
+ py27,py33,py34,py35,pypy,pypy3,coverage,docs
[testenv]
commands =