summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Yan <felixonmars@archlinux.org>2015-11-07 18:41:17 +0800
committerFelix Yan <felixonmars@archlinux.org>2015-11-07 18:41:17 +0800
commitf3e92fea5625e536abe508d91b3babfb28c8f849 (patch)
tree886d689e4a5bb0162784949b96af86989a5d4460
parent9547fd3704e9db089d356f2de08540accd9143f2 (diff)
downloadzope-event-f3e92fea5625e536abe508d91b3babfb28c8f849.tar.gz
Note explicit support for Python 3.5
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES.rst5
-rw-r--r--README.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
5 files changed, 9 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 49a0366..4f69fb2 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,7 @@ python:
- 3.2
- 3.3
- 3.4
+ - 3.5
- pypy
- pypy3
install:
diff --git a/CHANGES.rst b/CHANGES.rst
index 15d892c..1d6e112 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,11 @@
``zope.event`` Changelog
========================
+4.1.1 (unreleased)
+------------------
+
+- Claim support for Python 3.5.
+
4.1.0 (2015-10-18)
------------------
diff --git a/README.rst b/README.rst
index e79325a..2249fba 100644
--- a/README.rst
+++ b/README.rst
@@ -1,7 +1,7 @@
``zope.event`` README
=====================
-.. image:: https://pypip.in/version/zope.event/badge.svg?style=flat
+.. image:: https://img.shields.io/pypi/v/zope.event.svg
:target: https://pypi.python.org/pypi/zope.event/
:alt: Latest Version
diff --git a/setup.py b/setup.py
index 4f8f8a1..2936879 100644
--- a/setup.py
+++ b/setup.py
@@ -51,6 +51,7 @@ setup(
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: Jython",
"Programming Language :: Python :: Implementation :: PyPy",
diff --git a/tox.ini b/tox.ini
index 33d0c6a..a9268ff 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@ envlist =
# requests -> html5 libraries. See
# https://github.com/html5lib/html5lib-python/pull/150
# py26,py27,py32,py33,py34,pypy,pypy3,jython,coverage,docs
- py26,py27,py32,py33,py34,pypy,pypy3,coverage,docs
+ py26,py27,py32,py33,py34,py35,pypy,pypy3,coverage,docs
[testenv]
commands =