summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTres Seaver <tseaver@palladion.com>2016-04-15 01:49:22 -0400
committerTres Seaver <tseaver@palladion.com>2016-04-15 01:49:22 -0400
commit3003dadde38c86222008e12cb1dbbe34167a643e (patch)
treeffb2d0e6a92273a1766450dc0f78c8f25a90097c
parent92cd4531a9124f89858812fb8a71f8015c331c2d (diff)
parentca4b787bf131035521c4f374b4af6c32483fc8e7 (diff)
downloadzope-proxy-3003dadde38c86222008e12cb1dbbe34167a643e.tar.gz
Merge pull request #12 from zopefoundation/avoid-poisoning-wheel-cache-python-pure
Don't use/poison global wheel cache when building w/ PURE_PYTHON.
-rw-r--r--CHANGES.rst3
-rw-r--r--tox.ini4
2 files changed, 6 insertions, 1 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index cc90d96..5308515 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -4,6 +4,9 @@ Changes
4.2.0 (unreleased)
------------------
+- When testing ``PURE_PYTHON`` environments under ``tox``, avoid poisoning
+ the user's global wheel cache.
+
- Drop support for Python 2.6 and 3.2.
- Add support for Python 3.5.
diff --git a/tox.ini b/tox.ini
index e478a7b..47e65a9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -7,19 +7,21 @@ envlist =
[testenv]
commands =
- python setup.py test -q
+ python setup.py -q test -q
[testenv:py27-pure]
basepython =
python2.7
setenv =
PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache
[testenv:py33-pure]
basepython =
python3.3
setenv =
PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache
[testenv:jython]
commands =