summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jason+github@nextthought.com>2017-04-23 11:52:44 -0500
committerGitHub <noreply@github.com>2017-04-23 11:52:44 -0500
commit9d1d0e2cce40f4b7ce4d62afa418c7260244fdcd (patch)
tree48f62756193784414e2e1bf63f8a5571537a0641
parent2140ad3fca812cfcb7508307d601446b21994b66 (diff)
parent067eeccb90974692402dff91f5dddfccc8363fd3 (diff)
downloadzope-proxy-9d1d0e2cce40f4b7ce4d62afa418c7260244fdcd.tar.gz
Merge pull request #17 from zopefoundation/python36
Add support for Python 3.6
-rw-r--r--.travis.yml10
-rw-r--r--CHANGES.rst2
-rw-r--r--setup.py1
-rw-r--r--tox.ini5
4 files changed, 15 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index fa69368..32978e6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,10 +5,18 @@ python:
- 3.3
- 3.4
- 3.5
+ - 3.6
- pypy
install:
+ - pip install -U pip
+ - pip install -U setuptools
+ - pip install -U zope.testrunner
+ - pip install -U zope.security # We have a circular dependency for testing
- pip install -e .[test]
script:
- - python setup.py test -q
+ - zope-testrunner --test-path=src
notifications:
email: false
+cache: pip
+before_cache:
+ - rm -f $HOME/.cache/pip/log/debug.log
diff --git a/CHANGES.rst b/CHANGES.rst
index e5cb9e4..5479ad4 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -7,6 +7,8 @@ Changes
- Make the pure-Python implementation of ``sameProxiedObjects`` handle
``zope.security`` proxies. See `issue 15 <https://github.com/zopefoundation/zope.proxy/issues/15>`_.
+- Add support for Python 3.6.
+
4.2.0 (2016-05-05)
------------------
diff --git a/setup.py b/setup.py
index 0dc335d..be6ea07 100644
--- a/setup.py
+++ b/setup.py
@@ -71,6 +71,7 @@ setup(name='zope.proxy',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
"Framework :: Zope3",
diff --git a/tox.ini b/tox.ini
index 9049f13..8669b87 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,13 +3,14 @@ envlist =
# Jython support pending 2.7 support, due 2012-07-15 or so. See:
# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
# py27,jython,pypy,coverage
- py27,py27-pure,py33,py33-pure,py34,py35,pypy,coverage,docs
+ py27,py27-pure,py33,py33-pure,py34,py35,py36,pypy,coverage,docs
[testenv]
commands =
- python setup.py -q test -q
+ zope-testrunner --test-path=src
deps =
.[test]
+ zope.testrunner
[testenv:py27-pure]
basepython =