summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 13fc574..01f2f56 100644
--- a/setup.py
+++ b/setup.py
@@ -220,7 +220,8 @@ class build_ext(_build_ext):
extra_postargs=(ext.extra_compile_args or []),
depends=ext.depends)
except CompileError:
- log.warn("%s appears not to be installed" % ext.feature_name)
+ log.warn("%s appears not to be installed: forcing --%s"
+ % (ext.feature_name, ext.neg_option_name))
log.warn("(if %s is installed, you may need to specify"
% ext.feature_name)
log.warn(" the option --include-dirs or uncomment and modify")