summaryrefslogtreecommitdiff
path: root/examples/demos/photosurface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/demos/photosurface/CMakeLists.txt')
-rw-r--r--examples/demos/photosurface/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/examples/demos/photosurface/CMakeLists.txt b/examples/demos/photosurface/CMakeLists.txt
index d696882f..d60b9d18 100644
--- a/examples/demos/photosurface/CMakeLists.txt
+++ b/examples/demos/photosurface/CMakeLists.txt
@@ -12,7 +12,7 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/demos/photosurface")
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml Quick ShaderTools)
qt_standard_project_setup(REQUIRES 6.5)
@@ -55,6 +55,16 @@ qt_add_qml_module(photosurfaceexample
"resources/folder.png"
)
+qt6_add_shaders(photosurfaceexample "shaders"
+ BATCHABLE
+ PRECOMPILE
+ OPTIMIZED
+ PREFIX
+ "/qt/qml/photosurface"
+ FILES
+ "resources/shaders/gneiss.frag"
+)
+
install(TARGETS photosurfaceexample
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"