summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..5719308
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+from setuptools import setup
+
+setup(
+ name='qface',
+ version='1.0',
+ py_modules=['qface'],
+ install_requires=[
+ 'antlr4-python3-runtime',
+ 'jinja2',
+ 'click',
+ 'path.py',
+ 'watchdog',
+ 'pyyaml',
+ 'pytest',
+ 'ipdb'
+ ],
+ entry_points='''
+ [console_scripts]
+ qface=cli:cli
+ ''',
+)