summaryrefslogtreecommitdiff
path: root/examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt b/examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt
index 771443e..9a36218 100644
--- a/examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt
+++ b/examples/ivicore/qface-ivi-climate/frontend/CMakeLists.txt
@@ -21,13 +21,12 @@ find_package(Qt6 COMPONENTS IviCore)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
-)
-set_target_properties(QtIviClimateExample PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_compile_definitions(QtIviClimateExample PUBLIC
- QT_BUILD_EXAMPLE_IVI_CLIMATE_LIB
+add_library(QtIviClimateExample)
+
+# IVI Generator:
+qt6_ivigenerator(QtIviClimateExample
+ QFACE_SOURCES ../example-ivi-climate.qface
+ QFACE_FORMAT frontend
)
target_link_libraries(QtIviClimateExample PUBLIC