summaryrefslogtreecommitdiff
path: root/tests/auto/qgeocodingmanagerplugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qgeocodingmanagerplugins/CMakeLists.txt')
-rw-r--r--tests/auto/qgeocodingmanagerplugins/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/auto/qgeocodingmanagerplugins/CMakeLists.txt b/tests/auto/qgeocodingmanagerplugins/CMakeLists.txt
new file mode 100644
index 00000000..7521f9eb
--- /dev/null
+++ b/tests/auto/qgeocodingmanagerplugins/CMakeLists.txt
@@ -0,0 +1,14 @@
+qt_internal_add_plugin(GeocodingTestGeoServicePlugin
+ OUTPUT_NAME qtgeoservices_geocodingplugin
+ CLASS_NAME QGeoServiceProviderFactoryTest
+ PLUGIN_TYPE geoservices
+ DEFAULT_IF FALSE
+ SOURCES
+ qgeocodingmanagerengine_test.h
+ qgeoserviceproviderplugin_test.h
+ qgeoserviceproviderplugin_test.cpp
+ LIBRARIES
+ Qt::Core
+ Qt::Location
+ Qt::Positioning
+)