summaryrefslogtreecommitdiff
path: root/examples/designer/worldtimeclockplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/designer/worldtimeclockplugin/CMakeLists.txt')
-rw-r--r--examples/designer/worldtimeclockplugin/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/examples/designer/worldtimeclockplugin/CMakeLists.txt b/examples/designer/worldtimeclockplugin/CMakeLists.txt
index 114f4346a..8ae125320 100644
--- a/examples/designer/worldtimeclockplugin/CMakeLists.txt
+++ b/examples/designer/worldtimeclockplugin/CMakeLists.txt
@@ -3,28 +3,37 @@ project(worldtimeclockplugin LANGUAGES CXX)
set(CMAKE_AUTOMOC ON)
+#! [0]
find_package(Qt6 REQUIRED COMPONENTS Core Gui UiPlugin Widgets)
qt_add_plugin(worldtimeclockplugin)
+#! [0]
+
+#! [1]
target_sources(worldtimeclockplugin PRIVATE
worldtimeclock.cpp worldtimeclock.h
worldtimeclockplugin.cpp worldtimeclockplugin.h
)
+#! [1]
set_target_properties(worldtimeclockplugin PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+#! [2]
target_link_libraries(worldtimeclockplugin PUBLIC
Qt::Core
Qt::Gui
Qt::UiPlugin
Qt::Widgets
)
+#! [2]
if(QT6_INSTALL_PREFIX)
+#! [3]
set(INSTALL_EXAMPLEDIR "${QT6_INSTALL_PREFIX}/${QT6_INSTALL_PLUGINS}/designer")
+#! [3]
else()
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
@@ -32,8 +41,10 @@ else()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/plugins/designer")
endif()
+#! [4]
install(TARGETS worldtimeclockplugin
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
)
+#! [4]