summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-06-10 14:02:20 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-10 14:40:13 +0200
commite42e3f70547cf66e70f9b591e5f67fe95b9bfb96 (patch)
treeb15a64b4e5defc5d42f86522add813428385c6ff /CMakeLists.txt
parent09cb3a30900353dea710cf7d614087c0718dce52 (diff)
downloadqtwayland-e42e3f70547cf66e70f9b591e5f67fe95b9bfb96.tar.gz
CMake: Make ThemeSupport an optional component
It became an optional component after the qtbase change 788cd98b357fdc9dd8b0f0b1baf1033f0efa1f11 So make it optional. This fixes top-level builds on macOS (and probably other platforms). Amends 09cb3a30900353dea710cf7d614087c0718dce52 Change-Id: I1012923997201673b628a0ee5e512df31228f4cc Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1617721d..a3bb9e4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,7 +35,6 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
Core
Gui
EventDispatcherSupport
- ThemeSupport
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
@@ -47,9 +46,17 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
Quick
ServiceSupport
XkbCommonSupport
+ ThemeSupport
)
# special case end
+# special case begin
+# Moved above.
+#if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
+# message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
+# return()
+#endif()
+# special case end
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()