summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 16:23:03 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-09-22 17:58:46 +0000
commit67facb10f5c893ad7573093e03681b0e534dc9cf (patch)
tree92b9da0788301b5694114e361083248badb9e8dc /CMakeLists.txt
parent5a1e9d0daf7f518a14ee63e18f1f6559128f5df9 (diff)
downloadqtwayland-67facb10f5c893ad7573093e03681b0e534dc9cf.tar.gz
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Task-number: QTBUG-95018 Change-Id: I43575e48cb4ddb70b80f09e0432a2f88b01bec86 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Kai Koehne <kai.koehne@qt.io> (cherry picked from commit 5a2ebe329c1cce662d535dd652c8982c0c514ccb) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94afdcd1..f958eaf0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qtwayland.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtWayland # special case