summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-04-29 13:55:12 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-16 21:22:04 +0200
commit513a82539b5e0b28ad368f04bda5527521802dc2 (patch)
treef30a0ace463f6a9981e3a21481ff1bd931b7ad3f /CMakeLists.txt
parentfa5c5ed55dccf25b985d56cacbb6a3ea07bf61da (diff)
downloadqtwayland-513a82539b5e0b28ad368f04bda5527521802dc2.tar.gz
CMake: Unify "wayland components" qt_find_package() calls
So that the top-level call in src/CMakeLists.txt finds all the components, rather than doing it separately in each directory. This should prevent issues with dependency tracking of found packages even after the revert of dd7e40b1086020f6a054957f4972720cd6849280 in qtbase which is found at 8ddd3ee60bff1197b251feadf871fdaeb995ef3b. Amends 6319bc72e2dc63175ca797ee3042955f852e008f Change-Id: I05eef9db2de30a61b1aee532edc331b33fc027fb Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Simon Hausmann <hausmann@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1a32a25..340fe9e8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,14 +14,6 @@ project(QtWayland # special case
# TODO: Fix warnings and remove this
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
-# TODO: Remove this after qtbase revert of
-# dd7e40b1086020f6a054957f4972720cd684.
-# Needed for correct dependency tracking of Wayland::Client
-# and Wayland::Server in the separate qt_find_package() calls
-# so that standalone tests configure successfully.
-set(QT_FIND_PACKAGE_DISABLE_DEBUG_BEHAVIOR TRUE)
-
-# Find BuildInternals first by itself because it defines QNX
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
BuildInternals
)