summaryrefslogtreecommitdiff
path: root/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 17:35:07 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 21:20:17 +0100
commit41cb814d3d1382ffef39411fd94da215fab2b518 (patch)
tree9a5c6951030f13717b78caa71600f64a36fff702 /examples/wayland/custom-extension/cpp-client/CMakeLists.txt
parente89fa56d822cbc96951b60821b85794f3832d620 (diff)
downloadqtwayland-41cb814d3d1382ffef39411fd94da215fab2b518.tar.gz
CMake: Regenerate examples to set the WIN32_EXECUTABLE property
As well as the MACOSX_BUNDLE properties as necessary. Task-number: QTBUG-87664 Change-Id: I2e238dff7bdda6c47dfbe28e2a560ee4c25f3d02 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/wayland/custom-extension/cpp-client/CMakeLists.txt')
-rw-r--r--examples/wayland/custom-extension/cpp-client/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/wayland/custom-extension/cpp-client/CMakeLists.txt b/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
index e2afa3cf..3cb61a54 100644
--- a/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
+++ b/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
@@ -28,6 +28,10 @@ qt6_generate_wayland_protocol_client_sources(custom-extension-cpp-client
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../protocol/custom.xml
)
+set_target_properties(custom-extension-cpp-client PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(custom-extension-cpp-client PUBLIC
Qt::Core
Qt::Gui