summaryrefslogtreecommitdiff
path: root/tests/manual/CMakeLists.txt
diff options
context:
space:
mode:
authorEskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>2023-02-13 08:10:29 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-02-16 07:58:44 +0000
commit7d6b144818774573e07edbd652ad2209377046b3 (patch)
tree45ae230b3cdb9684c68b038dfa06ef58d249c7c7 /tests/manual/CMakeLists.txt
parent90e2ade38721febbf2cb8897779153de4d789a10 (diff)
downloadqtwayland-7d6b144818774573e07edbd652ad2209377046b3.tar.gz
Move server-buffer example to manual tests
This is undocumented and demonstrates an experimental feature which was never maintained or exercised. It's a nice feature, so we keep the example around for when we get the time to bring it back. Task-number: QTBUG-110993 Change-Id: I045cb2ef02a50017a26226c493607100ea0f1b95 Reviewed-by: Inho Lee <inho.lee@qt.io> (cherry picked from commit acb68bd3bbbc0001bcf460dd175ff92cc3ce594a) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/manual/CMakeLists.txt')
-rw-r--r--tests/manual/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/manual/CMakeLists.txt b/tests/manual/CMakeLists.txt
index 4393d4f1..d2f6959a 100644
--- a/tests/manual/CMakeLists.txt
+++ b/tests/manual/CMakeLists.txt
@@ -12,3 +12,7 @@ if(TARGET Qt::WaylandCompositor)
#add_subdirectory(wip-cpp-compositor)
add_subdirectory(scaling-compositor)
endif()
+
+if(QT_FEATURE_opengl AND TARGET Qt::Quick AND TARGET Qt::WaylandClient)
+ qt_internal_add_example(server-buffer)
+endif()