summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..33eee0c0
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,52 @@
+# Generated from qtwayland.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+project(QtWayland # special case
+ VERSION 6.0.0
+ DESCRIPTION "Qt Wayland Libraries" # special case
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+# special case begin
+# TODO: Fix warnings and remove this
+set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
+
+# TODO: Remove this after qtbase revert of
+# dd7e40b1086020f6a054957f4972720cd684.
+# Needed for correct dependency tracking of Wayland::Client
+# and Wayland::Server in the separate qt_find_package() calls
+# so that standalone tests configure successfully.
+set(QT_FIND_PACKAGE_DISABLE_DEBUG_BEHAVIOR TRUE)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
+ BuildInternals
+ Core
+ Gui
+ EventDispatcherSupport
+ FontDatabaseSupport
+ ThemeSupport
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
+ EglSupport
+ GlxSupport
+ LinuxAccessibilitySupport
+ PlatformCompositorSupport
+ Quick
+ ServiceSupport
+ VulkanSupport
+ XkbCommonSupport
+)
+# special case end
+
+if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
+ message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
+ return()
+endif()
+if(NOT TARGET Qt::Gui)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
+ return()
+endif()
+qt_build_repo()