summaryrefslogtreecommitdiff
path: root/tests/auto/client/shared/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/shared/CMakeLists.txt')
-rw-r--r--tests/auto/client/shared/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/auto/client/shared/CMakeLists.txt b/tests/auto/client/shared/CMakeLists.txt
index 8112ffb7..a1f150c2 100644
--- a/tests/auto/client/shared/CMakeLists.txt
+++ b/tests/auto/client/shared/CMakeLists.txt
@@ -53,10 +53,14 @@ qt6_generate_wayland_protocol_server_sources(SharedClientTest
${PROJECT_SOURCE_DIR}/src/3rdparty/protocol/xdg-shell.xml
)
+if(QT_FEATURE_opengl)
+ set(optional_libraries Qt::OpenGL)
+endif()
+
target_link_libraries(SharedClientTest
PUBLIC
Qt::Gui
- Qt::OpenGL
+ ${optional_libraries}
Qt::WaylandClientPrivate
Wayland::Server
Threads::Threads # special case