summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 876db610e..1a6bbfe9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,10 +163,12 @@ if(NOT Ninja_FOUND)
externalproject_add_stepdependencies(gn install ninja)
endif()
-# install resources (again), coin calls install with DESTDIR
-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/translations/qtwebengine_locales
- DESTINATION ${CMAKE_INSTALL_PREFIX}/translations
-)
-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/resources
- DESTINATION ${CMAKE_INSTALL_PREFIX}
-)
+if(NOT QT_FEATURE_framework)
+ # install resources (again), coin calls install with DESTDIR
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/translations/qtwebengine_locales
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/translations
+ )
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/resources
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
+ )
+endif()