summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* merge default into bug20099bug20099Matthias Radestock2009-01-1618-233/+603
|\ | | | | | | | | | | which involved a few conflict resolutions. The most complex of these was dealing with the termination of the limiter; we now unlink from it first so we don't get a spurious EXIT signal.
| * Merged 20071 into defaultBen Hood2009-01-1618-226/+599
| |\
| | * Merged 18557 into defaultBen Hood2009-01-164-89/+390
| | |\
| | | * add some commentsbug18557Matthias Radestock2009-01-152-2/+6
| | | |
| | | * Merged default into 18557Ben Hood2009-01-1521-163/+1021
| | | |\
| | | * | tidying up, refactoring and some cosmetic changesMatthias Radestock2008-12-264-61/+38
| | | | |
| | | * | cosmetic: rename 'in_use' to 'volume'Matthias Radestock2008-12-251-10/+10
| | | | |
| | | * | optimisation: only notify queues that have had can_send requests rejectedMatthias Radestock2008-12-251-18/+22
| | | | |
| | | * | destroy limiter when a channel becomes unlimitedMatthias Radestock2008-12-243-22/+38
| | | | | | | | | | | | | | | | | | | | which results in far more efficient handling of subsequent deliveries
| | | * | merge branch headsMatthias Radestock2008-12-240-0/+0
| | | |\ \
| | | | * | Remove unnecessary method name from protocol_errorTony Garnock-Jones2008-08-061-2/+1
| | | | | |
| | | | * | Special-case global=true: we don't implement itTony Garnock-Jones2008-08-061-0/+6
| | | | | |
| | | * | | don't leave the limiter behind when the channel terminatesMatthias Radestock2008-12-232-2/+13
| | | | | |
| | | * | | add type spec for start_linkMatthias Radestock2008-12-231-0/+1
| | | | | |
| | | * | | handle the "no limiter" case more obviouslyMatthias Radestock2008-12-231-10/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is no semantic change since gen_server:cast(undefined, ...) returns 'ok'. However, it only does so because it catches the 'badarg' error thrown by erlang:send. It is probably more efficient to not attempt the send in the first place. Plus for documentation purposes, and to keep dialyzer happy, it is useful to state explicitly which functions are expected to be called on an 'undefined' limiter.
| | | * | | cosmeticMatthias Radestock2008-12-231-20/+20
| | | | | |
| | | * | | deal with limiting after consumer subscriptionMatthias Radestock2008-12-233-19/+43
| | | | | |
| | | * | | create limiter lazilyMatthias Radestock2008-12-232-5/+22
| | | | | | | | | | | | | | | | | | | | | | | | This makes an 'unlimited' channel as efficient as it used to be
| | | * | | make limiter keep track of all queues with subscriptionsMatthias Radestock2008-12-232-18/+52
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is more efficient since it avoids the repeated (de)monitoring and updates to the limiter state.
| | | * | | merge default into bug18557Matthias Radestock2008-12-235-72/+286
| | | |\ \ \
| | | | * | | cosmeticMatthias Radestock2008-12-232-12/+12
| | | | | | |
| | | | * | | merge default into bug18557Matthias Radestock2008-12-234-17/+37
| | | | |\ \ \
| | | | * | | | ensure fairnessMatthias Radestock2008-12-231-4/+13
| | | | | | | |
| | | | * | | | saner state transition handlingMatthias Radestock2008-12-191-52/+39
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | and assorted bug fixes
| | | | * | | | fix bug: make sure consumers blocked due to limit are dropped from StateMatthias Radestock2008-12-191-5/+5
| | | | | | | |
| | | | * | | | handle transactional acksMatthias Radestock2008-12-191-18/+16
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | also: - simplify and optimise non-basic-get ack counting - don't talk to the limiter when there is nothing to tell, i.e. the non-basic-get ack count is zero
| | | | * | | | minor simplificationsMatthias Radestock2008-12-181-6/+4
| | | | | | | |
| | | | * | | | oopsMatthias Radestock2008-12-181-1/+1
| | | | | | | |
| | | | * | | | refactoringMatthias Radestock2008-12-181-18/+14
| | | | | | | |
| | | | * | | | tidy some more commentsMatthias Radestock2008-12-181-3/+3
| | | | | | | |
| | | | * | | | tidy commentsMatthias Radestock2008-12-181-11/+10
| | | | | | | |
| | | | * | | | lots of tweaks and fixesMatthias Radestock2008-12-181-48/+20
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - remove superfluous (or wrong) comments - notification and demonitoring always go together - don't change the in_use count when limit is altered - fix the limit_reached condition
| | | | * | | | fix typoMatthias Radestock2008-12-181-2/+2
| | | | | | | |
| | | | * | | | Added handler for monitor notificationsBen Hood2008-12-181-17/+6
| | | | | | | |
| | | | * | | | Don't double monitor anythingBen Hood2008-12-181-2/+5
| | | | | | | |
| | | | * | | | Put some monitors inBen Hood2008-12-182-20/+26
| | | | | | | |
| | | | * | | | Got rid of superfluous PD readBen Hood2008-12-181-2/+1
| | | | | | | |
| | | | * | | | Fix for multi ack bugBen Hood2008-12-181-1/+1
| | | | | | | |
| | | | * | | | add limiter to module listMatthias Radestock2008-12-181-0/+1
| | | | | | | |
| | | | * | | | merge default into bug18557Matthias Radestock2008-12-1871-890/+1680
| | | | |\ \ \ \ | | | | | | | | | | | | | | | | | | | | | | | | | | | and add license notice on rabbit_limiter
| | | | * | | | | Shutting dialyzer upBen Hood2008-12-072-6/+17
| | | | | | | | |
| | | | * | | | | Added catch for pre-fetch sizeBen Hood2008-12-071-0/+5
| | | | | | | | |
| | | | * | | | | Added match for setting the global flagBen Hood2008-12-071-0/+4
| | | | | | | | |
| | | | * | | | | Dead queue informs limiterBen Hood2008-12-073-1/+16
| | | | | | | | |
| | | | * | | | | Merged default into 18557Ben Hood2008-12-074-43/+236
| | | | |\ \ \ \ \
| | | | | * | | | | Differentiate between acks for basic.get and basic.consumeBen Hood2008-11-241-1/+13
| | | | | | | | | |
| | | | | * | | | | Now the channel sends the ack directly to the limiter instead of via the queueBen Hood2008-11-243-10/+12
| | | | | | | | | |
| | | | | * | | | | Minor fixesBen Hood2008-11-211-11/+15
| | | | | | | | | |
| | | | | * | | | | Changed prefetch from call to castBen Hood2008-11-211-6/+6
| | | | | | | | | |
| | | | | * | | | | Got rid o the per-queue in-use capacityBen Hood2008-11-212-31/+22
| | | | | | | | | |