summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2014-12-05 11:16:57 -0500
committerAdrian Thurston <thurston@complang.org>2014-12-05 11:16:57 -0500
commit96ee6203f047e9273234c2f5d69af08366bdb564 (patch)
tree34cb5faf0239f0bdb32887770c27b46f64355eff /configure.in
parent1b97f0fe6b47f2a8a3c4f3b91a9776098389b8df (diff)
downloadragel-96ee6203f047e9273234c2f5d69af08366bdb564.tar.gz
use AC_PATH_PROG for ragel and colm checks if no --with arg given
Advantage of this is that it locks the path in at configure time, so you don't get any surprises if the path changes between configure and make. Also shows the full path in the configure output.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bd98d488..7aee4e93 100644
--- a/configure.in
+++ b/configure.in
@@ -79,7 +79,7 @@ AC_ARG_WITH(ragel,
)
],
[
- AC_CHECK_PROG(RAGEL, ragel, ragel)
+ AC_PATH_PROG(RAGEL, ragel, ragel)
if test -z "$RAGEL"; then
echo
echo "error: ragel is required to build the parsers"
@@ -99,7 +99,7 @@ AC_ARG_WITH(kelbt,
)
],
[
- AC_CHECK_PROG(KELBT, kelbt, kelbt)
+ AC_PATH_PROG(KELBT, kelbt, kelbt)
if test -z "$KELBT"; then
echo
echo "error: kelbt is required to build the parsers"