summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2008-03-30 20:04:15 +0000
committerAdrian Thurston <thurston@complang.org>2008-03-30 20:04:15 +0000
commit3809a106e42621bc9962d9809aab62fc6b26a99a (patch)
treeae1f4ecc729c07497defb85b45c49f021c9dc238 /configure.in
parent4b9ecee1a8a9716665ba1fe0e2c7cd4c1c6ccc45 (diff)
downloadragel-3809a106e42621bc9962d9809aab62fc6b26a99a.tar.gz
C# patch Daniel Tang.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e74930fa..a257a709 100644
--- a/configure.in
+++ b/configure.in
@@ -112,7 +112,13 @@ if test -n "$RUBY"; then
AC_DEFINE_UNQUOTED(RUBY,$RUBY)
fi
+dnl Check for the C# compiler.
+AC_CHECK_PROG(GMCS, gmcs, gmcs)
+if test -n "$GMCS"; then
+ AC_DEFINE_UNQUOTED(GMCS,$GMCS)
+fi
+
dnl write output files
-AC_OUTPUT(Makefile common/Makefile ragel/Makefile redfsm/Makefile rlgen-cd/Makefile rlgen-java/Makefile rlgen-ruby/Makefile rlgen-dot/Makefile doc/Makefile test/Makefile)
+AC_OUTPUT(Makefile common/Makefile ragel/Makefile redfsm/Makefile rlgen-cd/Makefile rlgen-java/Makefile rlgen-ruby/Makefile rlgen-dot/Makefile rlgen-csharp/Makefile doc/Makefile test/Makefile)
echo "configuration of ragel complete"