summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2009-04-04 15:45:35 +0000
committerAdrian Thurston <thurston@complang.org>2009-04-04 15:45:35 +0000
commit3e533d48eeee917d7617fbe5a82925fca1800bf1 (patch)
tree016151a1d32825387d1e95e5cff0cc3ed3199dfd /test/Makefile.am
parent110d9909908be132fbadebde21108ef6321ab6f3 (diff)
downloadragel-3e533d48eeee917d7617fbe5a82925fca1800bf1.tar.gz
Moved the authoritative VERSION and PUBDATE to configure.in. Now generating
runtests from runtests.in so we can get the compiler substitutions in runtests. Also using automake in test/.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 00000000..492dec3c
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,34 @@
+#
+# Copyright 2002-2009 Adrian Thurston <thurston@complang.org>
+#
+
+# This file is part of Ragel.
+#
+# Ragel is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# Ragel is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Ragel; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+
+TESTS = runtests
+
+
+#clean:
+# rm -f *.c *.cpp *.m *.d *.java *.bin *.class *.exp \
+# *.out *_c.rl *_d.rl *_java.rl *_ruby.rl *_csharp.rl *.cs *.exe
+#
+#distclean: clean
+# rm -f Makefile
+#
+
+#Makefile: runtests
+