summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2016-11-04 13:10:12 +0200
committerPanu Matilainen <pmatilai@redhat.com>2016-11-04 13:16:02 +0200
commit3cac383bb848e01a9f236d33710ef043897f2a94 (patch)
tree8069738df350467502074dbaf53bd488956123e8 /Makefile.am
parentbd9f53bb7b0aaedb039e11be04e87b615c83c33a (diff)
downloadrpm-3cac383bb848e01a9f236d33710ef043897f2a94.tar.gz
Drop special hackery to force rpm into /bin/rpm
Let rpm go into $(bindir) along with everything else, it just isn't that special. Many distros are nowadays symlinkingbin to usr/bin anyway which makes the special casing of /bin/rpm even more silly. Somebody wants to put it someplace else, 'mv' is your friend and I'm not going to stop you.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ef0bdfd31..47bb4bd11 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -91,12 +91,7 @@ pkginclude_HEADERS += build/rpmfc.h
pkginclude_HEADERS += build/rpmspec.h
-rpmbindir = `echo $(bindir) | $(SED) -e s,usr/bin,bin,`
-rpmbin_PROGRAMS = rpm
-
-rpm_symlink_prefix = `case "$(bindir)" in *usr/bin*) echo '../../bin/';; *) echo '';; esac`
-
-bin_PROGRAMS = rpm2cpio rpmbuild rpmdb rpmkeys rpmsign rpmspec
+bin_PROGRAMS = rpm rpm2cpio rpmbuild rpmdb rpmkeys rpmsign rpmspec
if WITH_ARCHIVE
bin_PROGRAMS += rpm2archive
endif