summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-10-01 10:43:55 +0300
committerPanu Matilainen <pmatilai@redhat.com>2010-10-01 10:43:55 +0300
commita4adf99b0f81c2ab72ade92850cfb9b5cf8ffbca (patch)
tree0014aab2441bb0b6b4e32620ecfa5482cab2205a /Makefile.am
parent8b4ccff2e36876dcfbdba9f38f4ec9dcdef2166e (diff)
downloadrpm-a4adf99b0f81c2ab72ade92850cfb9b5cf8ffbca.tar.gz
Add configure switch to disable plugins build
- For now this is really just to allow building statically while hacking, for "real world" use this has implications on collections support etc which is not handled by this patch.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 456d239c8..9ff6d3cae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,12 +19,16 @@ endif
if WITH_LUAEXT
SUBDIRS += luaext
endif
-SUBDIRS += rpmio lib build scripts fileattrs doc . tests plugins
+SUBDIRS += rpmio lib build scripts fileattrs doc . tests
if ENABLE_PYTHON
SUBDIRS += python
endif
+if ENABLE_PLUGINS
+SUBDIRS += plugins
+endif
+
DIST_SUBDIRS = po misc luaext rpmio lib build python scripts fileattrs doc tests plugins
pkgconfigdir = $(libdir)/pkgconfig