summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlorian Festi <ffesti@redhat.com>2014-03-05 13:52:40 +0100
committerFlorian Festi <ffesti@redhat.com>2014-03-11 10:49:55 +0100
commitd24a1f8eecb26bcda77cbead7d42c5d2c46f869b (patch)
treece5dfdeb9ea745bbf0201306e9c678ba45360fad /Makefile.am
parent7ab9b19bd74b895450c5247a8da0aa3c68616105 (diff)
downloadrpm-d24a1f8eecb26bcda77cbead7d42c5d2c46f869b.tar.gz
Add rpm2archive utility for converting rpm payload to tar archives.
This is needed as the new payload format for large files is not compatible with rpm2cpio which basically just dumps the payload which happened to be cpio. Use configure parameter --without-archive to not build this tool and get rid of the libarchive requirement.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 54cc5e8a6..bfcc4b447 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,6 +96,9 @@ rpmbindir = `echo $(bindir) | $(SED) -e s,usr/bin,bin,`
rpmbin_PROGRAMS = rpm
bin_PROGRAMS = rpm2cpio rpmbuild rpmdb rpmkeys rpmsign rpmspec
+if WITH_ARCHIVE
+bin_PROGRAMS += rpm2archive
+endif
rpmlibexec_PROGRAMS =
rpmconfig_SCRIPTS = autodeps/find-provides autodeps/find-requires \
@@ -150,6 +153,10 @@ rpm2cpio_SOURCES = rpm2cpio.c debug.h system.h
rpm2cpio_LDADD = lib/librpm.la rpmio/librpmio.la
rpm2cpio_LDADD += @WITH_NSS_LIB@ @WITH_POPT_LIB@ @WITH_ZLIB_LIB@
+rpm2archive_SOURCES = rpm2archive.c debug.h system.h
+rpm2archive_LDADD = lib/librpm.la rpmio/librpmio.la
+rpm2archive_LDADD += @WITH_NSS_LIB@ @WITH_POPT_LIB@ @WITH_ZLIB_LIB@ @WITH_ARCHIVE_LIB@
+
if LIBELF
if LIBDWARF