summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2020-03-23 11:19:09 +0200
committerPanu Matilainen <pmatilai@redhat.com>2020-03-23 13:44:29 +0200
commit60baf9c297f675c2ef2b82bf5af96b26a003d129 (patch)
tree19ebfa69214e2cfbf673d4448c022fc6a9fadd21 /configure.ac
parentcec09e4e00dbc47c32bec15304ad9490ec7bc6c4 (diff)
downloadrpm-60baf9c297f675c2ef2b82bf5af96b26a003d129.tar.gz
Deprecate beecrypt support
Beecrypt upstream is dead for seven years, this is not a healthy situation (death tends to have that effect...) for any component, and even less so for security sensitive component. Deprecate for later removal now that we have multiple nicer alternatives.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d09f4803f..d5ce5efaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,12 +272,12 @@ AM_CONDITIONAL(LIBDWARF,[test "$WITH_LIBDWARF" = yes])
# Select crypto library
AC_ARG_WITH(crypto,
[AC_HELP_STRING([--with-crypto=CRYPTO_LIB],
- [The cryptographic library to use (nss|beecrypt|openssl|libgcrypt). The default is libgcrypt.])
+ [The cryptographic library to use (nss|beecrypt|openssl|libgcrypt). The default is libgcrypt. beecrypt is DEPRECATED.])
],[],
[with_crypto=libgcrypt])
# Check for beecrypt library if requested.
-AC_ARG_WITH(internal_beecrypt, [ --with-internal-beecrypt build with internal beecrypt library ],,[with_internal_beecrypt=no])
+AC_ARG_WITH(internal_beecrypt, [ --with-internal-beecrypt build with internal beecrypt library (DEPRECATED)],,[with_internal_beecrypt=no])
AM_CONDITIONAL([WITH_INTERNAL_BEECRYPT],[test "$with_internal_beecrypt" = yes])
if test "$with_internal_beecrypt" = yes ; then
with_crypto=beecrypt