summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c7bfaf7b8..a1e961678 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,6 +10,10 @@ CLEANFILES =
TESTSUITE = $(srcdir)/rpmtests
EXTRA_DIST += local.at $(TESTSUITE)
+AM_CPPFLAGS = -I$(top_builddir)/include
+
+rpmpgpcheck_LDADD = ../rpmio/librpmio.la
+
## testsuite components
TESTSUITE_AT = rpmtests.at
TESTSUITE_AT += rpmgeneral.at
@@ -131,6 +135,8 @@ EXTRA_DIST += data/misc/libhello.so
.PHONY: populate_testing
+check_PROGRAMS = rpmpgpcheck
+
# testsuite voodoo
AUTOTEST = $(AUTOM4TE) --language=autotest
$(TESTSUITE): $(srcdir)/package.m4 local.at $(TESTSUITE_AT)