summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Disable one test which requires changes to require_plugin() which will be ↵OC-9924sersut2013-12-133-32/+17
| | | | done as a separate PR in order to keep this PR small.
* Refactor hints to its own class.sersut2013-12-136-73/+199
|
* This PR includes a few refactorings. Since they are intertwined they are ↵sersut2013-12-1313-306/+275
| | | | | | | | | | done in a single PR :( 1-) VersionVI and VersionVII classes are moved to their own classes. 2-) VersionVII class only gets the data instead of full System object. 3-) A new integration testing infrastructure is started (similar to Chef integration tests). 4-) Loader code is refactored. 5-) New integration tests for Loader are added.
* Move VersionVI and VersionVII plugin classes into their own files.sersut2013-12-128-119/+181
|
* Merge pull request #236 from opscode/fix-windows-testsSeth Chisamore2013-12-051-4/+11
|\ | | | | Clean up `jenkins_run_tests.bat`
| * Clean up `jenkins_run_tests.bat`Seth Chisamore2013-12-051-4/+11
|/ | | | This change ensures the bat file is in sync with what we have in opscode/chef.
* Merge branch 'plugin-provider-cleanup'danielsdeleo2013-12-0412-220/+295
|\ | | | | | | Extract a class to maintain the provided attributes to providing plugins mapping
| * Remove no-longer-relevant "TODO"danielsdeleo2013-12-041-1/+0
| |
| * Rename variables/methods for ProvidesMap to provides_mapdanielsdeleo2013-12-049-40/+41
| | | | | | | | | | | | | | | | | | The name "attributes" to refer to the map of attributes<->plugins providing attributes was confusing because it was inaccurate and often used near a local variable named "attributes" containing a very different kind of data (such as an Array of strings referring to attributes another plugin depended on). Renaming to "provides_map" clears up the confusion.
| * Remove access to ProvidesMap internal data structuredanielsdeleo2013-12-044-28/+13
| | | | | | | | | | Only test code was accessing this, modified to use the public API of the class.
| * Extract ProvidesMap and tests to their own filesdanielsdeleo2013-12-046-211/+245
| | | | | | | | | | | | Also eliminates redundant tests in other classes that primarily test ProvidesMap behavior. Higher-level tests have been left in place to verify the interaction of the components.
| * Extract plugin<->provides mapping to custom classdanielsdeleo2013-12-045-72/+125
| | | | | | | | | | | | | | | | Code to map a plugin to the attributes it provides or look up a plugin by provided attributes was located in different parts of the code base where it operated directly on the underlying data structure. Extracting to a class lets us access the information we want using domain specific terminology so things are easier to understand.
| * Add support for :focus tests to spec helperdanielsdeleo2013-12-041-0/+4
| |
| * Fix warnings in DSL::Plugin specdanielsdeleo2013-12-041-12/+11
|/
* OHAI-529 ensure virtual IPs are never chosen for privateaddressEric Saxby2013-11-262-13/+25
| | | | | - Refactor privateaddress logic into smaller, more clear methods based on comments from @btm - Make rspec descriptions a little more readable
* OHAI-529 Remove ipaddr_extension from GemfileEric Saxby2013-11-262-48/+56
| | | | | | Specs for the ip_scopes plugin can be run in two ways: * Run rspec in the context of `bundle exec` * Install ipaddr_extensions, then run rspec outside of `bundle exec`
* OHAI-529 sort interfaces in ip_scopes before assigning privateaddressEric Saxby2013-11-261-1/+1
| | | | | | Hash keys are ordered in Ruby > 1.9, so the plugin behaved differently between 1.8 and newer versions. In order to make the code (and tests) more deterministic, let's sort network interfaces before doing work.
* OHAI-529: ip_scopes prefers ethernet to pppEric Saxby2013-11-263-2/+91
| | | | | | | | | On hosts with virtual interfaces on RFC1918 networks, the ip_scopes plugin may set `node.privateaddress` to a virtual address. This can cause problems with automation that relies on the `privateaddress` attribute. This patch prefers non-ppp interfaces when setting `privateaddress`, though it will use ppp interfaces if they are the only ones.
* Merge branch 'OHAI-358'Bryan McLellan2013-11-252-3/+10
|\
| * update test with current masterElan Ruusamäe2013-11-251-3/+1
| | | | | | | | | | | | | | | | test passes: $ ruby -S rspec spec/unit/plugins/php_spec.rb Conflicts: spec/unit/plugins/php_spec.rb
| * [OHAI-358] add test for php version parseElan Ruusamäe2013-11-251-0/+9
| |
| * [OHAI-509] fix build date parsing from php if php patched with suhosin:Elan Ruusamäe2013-11-251-3/+3
|/ | | | | | | | | | $ php -v PHP 5.3.27 with Suhosin-Patch (cli) (built: Aug 30 2013 04:30:30) Copyright (c) 1997-2013 The PHP Group Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies Conflicts: lib/ohai/plugins/php.rb
* OHAI-525 : can now detect qemu/kvm according the cpu typeThibaut Notteboom2013-11-252-1/+17
|
* Merge branch 'OHAI-527'Bryan McLellan2013-11-251-0/+19
|\
| * added comment to help someonecaryp2013-11-131-0/+19
|/
* Merge branch 'OHAI-514'danielsdeleo2013-11-112-93/+171
|\ | | | | | | Fixes OHAI-514, https://tickets.opscode.com/browse/OHAI-514
| * Fix Mac OS X stub java workaroundOHAI-514danielsdeleo2013-11-072-93/+171
|/
* Remove self-dependency in libvirt plugindanielsdeleo2013-11-071-2/+0
|
* Merge pull request #221 from tas50/OHAI-522Bryan McLellan2013-11-061-1/+1
|\ | | | | Correct help output to reference ohai not chef
| * Correct help output to reference ohai not chefTim Smith2013-10-311-1/+1
| |
* | Merge branch 'OHAI-495'Bryan McLellan2013-11-042-11/+25
|\ \
| * | Update Virtualbox guest test for the dmidecode detectionTim Smith2013-11-041-8/+20
| | |
| * | Detect virtualbox guests via dmidecode so guest additions aren'tTim Smith2013-11-041-3/+5
|/ / | | | | | | required
* | Merge pull request #217 from opscode/OC-10247Claire McQuin2013-10-3012-33/+55
|\ \ | |/ |/| Fail Ohai when > 1 collect_data blocks defined per platform
| * fix mime-types dependency versionClaire McQuin2013-10-292-2/+4
| |
| * check for detailed warning messageClaire McQuin2013-10-291-1/+1
| |
| * add exceptions to ohai/exception.rbClaire McQuin2013-10-2910-36/+26
| |
| * add PluginDefinitionError to Ohai, rescue in loader.rbClaire McQuin2013-10-295-4/+28
| |
| * fail when more than one collect_data blocks defined per platformClaire McQuin2013-10-293-14/+20
|/
* Add a CONTRIBUTING documentBryan McLellan2013-10-241-0/+153
| | | | Copied from Chef, updated a bit for Ohai and recent changes
* Merge pull request #214 from opscode/OC-10249Claire McQuin2013-10-178-112/+135
|\ | | | | Rename providers -> plugins && seperate v6 methods from v7 methods in system.rb
| * collect v7 methods at top and collect v6 methods at bottom of system.rbClaire McQuin2013-10-171-33/+43
| |
| * change _providers to _pluginsClaire McQuin2013-10-178-80/+93
| |
* | Merge pull request #208 from opscode/OC-9409Claire McQuin2013-10-17185-2258/+1561
|\ \ | |/ | | Add platform option to collect_data
| * update new solaris2 plugins and specsClaire McQuin2013-10-174-6/+6
| |
| * update spec_helper, system_spec to Ohai::Mixin::OSClaire McQuin2013-10-172-3/+3
| |
| * actually make os a mixin and update corresponding filesClaire McQuin2013-10-174-33/+35
| |
| * change :providers to :_providers to avoid attribute conflictsClaire McQuin2013-10-178-32/+32
| |
| * insert plugin documentation URL to v6 deprecation messageClaire McQuin2013-10-171-1/+1
| |
| * remove @todo that was doneClaire McQuin2013-10-171-1/+0
| |