summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornagachika <nagachika@ruby-lang.org>2022-06-18 16:05:31 +0900
committernagachika <nagachika@ruby-lang.org>2022-06-18 16:05:31 +0900
commit702f7c8417e2a47bd88ef72fd705c1739cd958de (patch)
tree863f284ac0a8f4dcedb8f82c004d24b1212a379a /configure.ac
parent607a20b000f83003958e92b68319e860094f44fc (diff)
downloadruby-702f7c8417e2a47bd88ef72fd705c1739cd958de.tar.gz
merge revision(s) 222203297966f312109e8eaa2520f2cf2f59c09d: [Backport #18672]
Remove dependency on libcapstone We have received reports of build failures due to this configuration check modifying compile flags. Since only YJIT devs use this library we can remove it to make Ruby easier to build for users. See: https://github.com/rbenv/ruby-build/discussions/1933 --- configure.ac | 9 --------- 1 file changed, 9 deletions(-)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 5a6b074f8a..951a664aa5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1244,15 +1244,6 @@ AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
AC_CHECK_LIB(socket, shutdown) # SunOS/Solaris
-if pkg-config --exists capstone; then
- CAPSTONE_CFLAGS=`pkg-config --cflags capstone`
- CAPSTONE_LIB_L=`pkg-config --libs-only-L capstone`
- LDFLAGS="$LDFLAGS $CAPSTONE_LIB_L"
- CFLAGS="$CFLAGS $CAPSTONE_CFLAGS"
-fi
-
-AC_CHECK_LIB(capstone, cs_open) # Capstone disassembler for debugging YJIT
-
dnl Checks for header files.
AC_HEADER_DIRENT
dnl AC_HEADER_STDC has been checked in AC_USE_SYSTEM_EXTENSIONS