summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlex Crichton <alex@alexcrichton.com>2018-11-19 22:14:05 -0800
committerAlex Crichton <alex@alexcrichton.com>2018-11-21 15:27:56 -0800
commit91bd079e23b6a2128ef605de316465068ba355d8 (patch)
treec1611c5eae5b1756b46f7306d0259a6db45fed0d /Cargo.toml
parent5b403753da9ec8ff501adf34cb6d63b319b4a3ae (diff)
downloadrust-libc-91bd079e23b6a2128ef605de316465068ba355d8.tar.gz
Prepare for being included via crates.io into std
This commit prepares the `libc` crate to be included directly into the standard library via crates.io. More details about this can be found on rust-lang/rust#56092, but the main idea is that this crate now depends on core/compiler-builtins explicitly (but off-by-default). The main caveat here is that this activates `no_core` when building as part of libstd, which means that it needs to explicitly have an `iter` and `option` module for the expansion of `for` loops to work.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 719470d383..f3e57f83ad 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,6 @@
[package]
-
name = "libc"
-version = "0.2.43"
+version = "0.2.44"
authors = ["The Rust Project Developers"]
license = "MIT OR Apache-2.0"
readme = "README.md"
@@ -19,10 +18,14 @@ exclude = ["/ci/*", "/.travis.yml", "/appveyor.yml"]
travis-ci = { repository = "rust-lang/libc" }
appveyor = { repository = "rust-lang/libc", project_name = "rust-lang-libs/libc" }
+[dependencies]
+rustc-std-workspace-core = { version = "1.0.0", optional = true }
+
[features]
default = ["use_std"]
use_std = []
align = []
+rustc-dep-of-std = ['align', 'rustc-std-workspace-core']
[workspace]
members = ["libc-test"]