summaryrefslogtreecommitdiff
Commit message (Expand)AuthorAgeFilesLines
* slight clarification to error messagenellshamrell/fix-80658Nell Shamrell2021-01-181-1/+1
* adds a small clarification for when an async function's output is opaqueNell Shamrell2021-01-101-1/+1
* Auto merge of #80789 - Aaron1011:fix/stmt-empty, r=petrochenkovbors2021-01-103-1/+50
|\
| * Synthesize a `TokenStream` for `StmtKind::Empty`Aaron Hill2021-01-093-1/+50
* | Auto merge of #80391 - ssomers:btree_cleanup_slices_3, r=Mark-Simulacrumbors2021-01-101-26/+32
|\ \
| * | BTreeMap: tougher checks on most uses of copy_nonoverlappingStein Somers2021-01-081-26/+32
* | | Auto merge of #80867 - JohnTitor:rollup-tvqw555, r=JohnTitorbors2021-01-1045-171/+299
|\ \ \
| * \ \ Rollup merge of #80857 - camelid:vec-truncate-comment, r=scottmcmYuki Okushi2021-01-101-0/+3
| |\ \ \
| | * | | Add comment to `Vec::truncate` explaining `>` vs `>=`Camelid2021-01-091-0/+3
| | | |/ | | |/|
| * | | Rollup merge of #80850 - m-ou-se:rustc-builtin-macro-name, r=petrochenkovYuki Okushi2021-01-105-15/+13
| |\ \ \
| | * | | Don't set builtin_name for builtin macro implementations.Mara Bos2021-01-091-1/+1
| | * | | Formatting.Mara Bos2021-01-091-1/+3
| | * | | Allow #[rustc_builtin_macro = "name"].Mara Bos2021-01-095-15/+11
| * | | | Rollup merge of #80825 - GuillaumeGomez:rustdoc-cleanup-bis-repetita, r=jyn514Yuki Okushi2021-01-109-32/+28
| |\ \ \ \
| | * | | | Replace under-used ImplPolarity enum with a booleanGuillaume Gomez2021-01-099-32/+27
| | * | | | Add doc comment explaining what the second Array's field is aboutGuillaume Gomez2021-01-081-0/+1
| * | | | | Rollup merge of #80820 - nagisa:nagisa/dcl-nixos, r=Mark-SimulacrumYuki Okushi2021-01-101-8/+15
| |\ \ \ \ \
| | * | | | | Support `download-ci-llvm` on NixOSSimonas Kazlauskas2021-01-091-8/+15
| | |/ / / /
| * | | | | Rollup merge of #80803 - jyn514:cleanup-fill-in, r=GuillaumeGomezYuki Okushi2021-01-101-49/+40
| |\ \ \ \ \
| | * | | | | Remove useless `fill_in` functionJoshua Nelson2021-01-071-49/+40
| | | |_|/ / | | |/| | |
| * | | | | Rollup merge of #80801 - estebank:correct-binding-sugg-span, r=petrochenkovYuki Okushi2021-01-1027-64/+146
| |\ \ \ \ \
| | * | | | | Use correct span for structured suggestionEsteban Küber2021-01-0727-64/+146
| | |/ / / /
| * | | | | Rollup merge of #80774 - LingMan:patch-1, r=nagisaYuki Okushi2021-01-101-2/+3
| |\ \ \ \ \
| | * | | | | Fix safety commentLingMan2021-01-071-2/+3
| * | | | | | Rollup merge of #79968 - bjorn3:better_drop_glue_debuginfo, r=matthewjasperYuki Okushi2021-01-101-1/+9
| |\ \ \ \ \ \
| | * | | | | | Simplify based on eddyb's commentbjorn32020-12-171-21/+9
| | * | | | | | Use better symbol names for the drop gluebjorn32020-12-121-0/+20
| * | | | | | | Rollup merge of #79502 - Julian-Wollersberger:from_char_for_u64, r=withoutboatsYuki Okushi2021-01-101-0/+42
| |\ \ \ \ \ \ \
| | * | | | | | | Update the stabilisation version.Julian Wollersberger2021-01-091-2/+2
| | * | | | | | | Implement From<char> for u64 and u128.Julian Wollersberger2020-11-281-0/+42
* | | | | | | | | Auto merge of #77862 - danielhenrymantilla:rustdoc/fix-macros_2_0-paths, r=jy...bors2021-01-106-13/+163
|\ \ \ \ \ \ \ \ \ | |/ / / / / / / / |/| | | | | | | |
| * | | | | | | | Apply suggestions from code review & other minor nitsDaniel Henry-Mantilla2021-01-071-7/+10
| * | | | | | | | Fix rebase and clean up some code.Daniel Henry-Mantilla2021-01-061-22/+8
| * | | | | | | | Fixed non-declarative-nor-opaque macros effective privacy.Daniel Henry-Mantilla2021-01-061-14/+8
| * | | | | | | | Fix ICE on `pub macro`s defined within a non-module type namespace.Daniel Henry-Mantilla2021-01-062-5/+21
| * | | | | | | | Style nit: avoid confusing name shadowing in pattern matchDaniel Henry-Mantilla2021-01-061-2/+2
| * | | | | | | | Enhance tests based on code reviewDaniel Henry-Mantilla2021-01-061-1/+2
| * | | | | | | | WIP: attempt to fix the undocument re-export issueDaniel Henry-Mantilla2021-01-061-2/+13
| * | | | | | | | Update test assertions (showcases bug)Daniel Henry-Mantilla2021-01-062-7/+31
| * | | | | | | | Style nit: replace `for_each` & `return` with `for` & `continue`Daniel Henry-Mantilla2021-01-063-12/+21
| * | | | | | | | Fix type/value namespace clashes + test for thatDaniel Henry-Mantilla2021-01-063-44/+85
| * | | | | | | | Implement suggestions from code review.Daniel Henry-Mantilla2021-01-062-25/+35
| * | | | | | | | Rustdoc: Fix macros 2.0 and built-in derives being shown at the wrong path.Daniel Henry-Mantilla2021-01-062-5/+60
| | |_|_|_|_|_|/ | |/| | | | | |
* | | | | | | | Auto merge of #80831 - jyn514:no-inline, r=Mark-Simulacrumbors2021-01-101-1/+0
|\ \ \ \ \ \ \ \
| * | | | | | | | Don't mark `force_query_with_job` as `inline(always)`Joshua Nelson2021-01-081-1/+0
* | | | | | | | | Auto merge of #80441 - petrochenkov:kwtok, r=Aaron1011bors2021-01-0912-50/+72
|\ \ \ \ \ \ \ \ \
| * | | | | | | | | ast: Remove some indirection layers from values in key-value attributesVadim Petrochenkov2021-01-0912-50/+72
* | | | | | | | | | Auto merge of #80830 - Aaron1011:capture-token-empty-stack, r=petrochenkovbors2021-01-091-1/+9
|\ \ \ \ \ \ \ \ \ \
| * | | | | | | | | | Use an empty `TokenCursorFrame` stack when capturing tokensAaron Hill2021-01-081-1/+9
| | |/ / / / / / / / | |/| | | | | | | |
* | | | | | | | | | Auto merge of #80563 - petrochenkov:expattronmac, r=Aaron1011bors2021-01-098-40/+63
|\ \ \ \ \ \ \ \ \ \ | |_|/ / / / / / / / |/| | | | | | | | |