summaryrefslogtreecommitdiff
path: root/packaging/rvi_core.spec
diff options
context:
space:
mode:
authorGunnar Andersson <gandersson@genivi.org>2018-05-30 16:19:10 +0200
committerGunnar Andersson <gandersson@genivi.org>2018-07-27 16:33:10 +0200
commit90f8589f899e924e3c1a9f167897d1f1c2440b49 (patch)
tree2cc7651727901de6037f2f1c377ee610830781ad /packaging/rvi_core.spec
parentd63dd1c7c9659a2d99a7f1a4f47906a01f5619ae (diff)
downloadrvi_core-90f8589f899e924e3c1a9f167897d1f1c2440b49.tar.gz
Change all paths from /opt to /usr/shareinstall_to_usr
/opt can't be used in an normal OS-tree compatible layout - program files should now reside under /usr. /etc/opt/<rvi config files> changed to remove opt which looks odd there anyway: --> /etc/rvi/<config files>. Also moved default log location to /run/log/rvi_core because ${target_dir}/log is not adequate when the installation (target) dir is read-only. Note that /run is non-persistent, so /var/log might be preferred later. Signed-off-by: Gunnar Andersson <gandersson@genivi.org>
Diffstat (limited to 'packaging/rvi_core.spec')
-rwxr-xr-xpackaging/rvi_core.spec12
1 files changed, 6 insertions, 6 deletions
diff --git a/packaging/rvi_core.spec b/packaging/rvi_core.spec
index 28fe76b..350d2a0 100755
--- a/packaging/rvi_core.spec
+++ b/packaging/rvi_core.spec
@@ -28,16 +28,16 @@ make compile
./scripts/setup_rvi_node.sh -n rvi_tizen -c ./packaging/tizen.config
%install
rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION
-cp -ar rel/rvi_tizen $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION
-cp -ar python $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION
+mkdir -p $RPM_BUILD_ROOT/usr/share/rvi-$RPM_PACKAGE_VERSION
+cp -ar rel/rvi_tizen $RPM_BUILD_ROOT/usr/share/rvi-$RPM_PACKAGE_VERSION
+cp -ar python $RPM_BUILD_ROOT/usr/share/rvi-$RPM_PACKAGE_VERSION
mkdir -p $RPM_BUILD_ROOT/usr/lib/systemd/system/
mkdir -p $RPM_BUILD_ROOT/etc/systemd/system/multi-user.target.wants/
install ./scripts/rvi.service $RPM_BUILD_ROOT/usr/lib/systemd/system/rvi.service
ln -fsr $RPM_BUILD_ROOT/usr/lib/systemd/system/rvi.service \
$RPM_BUILD_ROOT/etc/systemd/system/multi-user.target.wants/rvi.service
-ln -fsr $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION/releases/$RPM_PACKAGE_VERSION/sys.config \
- $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION/sys.config
+ln -fsr $RPM_BUILD_ROOT/usr/share/rvi-$RPM_PACKAGE_VERSION/releases/$RPM_PACKAGE_VERSION/sys.config \
+ $RPM_BUILD_ROOT/usr/share/rvi-$RPM_PACKAGE_VERSION/sys.config
mkdir -p $RPM_BUILD_ROOT/home/app/content/Documents
echo "default_vin" > $RPM_BUILD_ROOT/home/app/content/Documents/vin
@@ -50,4 +50,4 @@ rm -rf $RPM_BUILD_ROOT
%attr(644,app,users) /home/app/content/Documents/vin
/usr/lib/systemd/system/rvi.service
/etc/systemd/system/multi-user.target.wants/rvi.service
-/opt/rvi-0.5.1
+/usr/share/rvi-0.5.1